
R&S®SMW-K540, R&S®SMW-K541
Envelope Tracking and AM/AM,
AM/PM Predistortion
User Manual

Us
er

 M
an

ua
l

 
1176.9506.02 ─ 07
(;Úí62)

Te
st 

& 
Me

as
ur

em
en

t



This document describes the following software options:

● R&S®SMW-K540
1413.7215.xx

● R&S®SMW-K541
1413.7267.xx

This manual describes firmware version FW 3.20.324.xx and later of the R&S®SMW200A.

© 2015 Rohde & Schwarz GmbH & Co. KG
Mühldorfstr. 15, 81671 München, Germany
Phone: +49 89 41 29 - 0
Fax: +49 89 41 29 12 164
Email: info@rohde-schwarz.com
Internet: www.rohde-schwarz.com
Subject to change – Data without tolerance limits is not binding.
R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.
Trade names are trademarks of the owners.

The following abbreviations are used throughout this manual: R&S®SMW200A is abbreviated as R&S SMW; the license types
02/03/07/11/13/16/12 are abbreviated as xx.

mailto:info@rohde-schwarz.com
http://www.rohde-schwarz.com


ContentsR&S®SMW-K540, R&S®SMW-K541

3User Manual 1176.9506.02 ─ 07

Contents
1 Preface.................................................................................................... 5

1.1 About this Manual......................................................................................................... 5

1.2 Documentation Overview............................................................................................. 5

1.3 Conventions Used in the Documentation...................................................................7

1.3.1 Typographical Conventions.............................................................................................7

1.3.2 Conventions for Procedure Descriptions.........................................................................8

1.3.3 Notes on Screenshots.....................................................................................................8

2 Welcome to the R&S SMW-K540/-K541 Options.................................9
2.1 Accessing the Required Settings.............................................................................. 10

2.2 Scope........................................................................................................................... 10

3 Generation of Envelope Tracking Signals.........................................11
3.1 Required Options........................................................................................................ 11

3.2 About the Envelope Tracking.................................................................................... 11

3.2.1 Envelope Voltage Adaptation Modes............................................................................ 12

3.2.2 Signal Parameters for Testing According to the eTrak® Specification.......................... 13

3.2.3 Envelope Shaping and Shaping Methods..................................................................... 13

3.2.3.1 About the Linear Functions........................................................................................... 14

3.2.3.2 About the Detroughing Function................................................................................... 15

3.2.3.3 About the Polynomial Function..................................................................................... 15

3.2.3.4 About the Shaping Table...............................................................................................16

3.2.3.5 Shaping Function in Raw Data Format......................................................................... 17

3.2.3.6 Converting Shaping Functions and Understanding the Displayed Values....................17

3.3 General RF Envelope Settings...................................................................................22

3.4 Envelope Settings....................................................................................................... 31

3.5 Shaping Settings.........................................................................................................33

3.6 Edit I/Q Envelope Shape Settings..............................................................................41

3.7 Polynomial Coefficients Setting................................................................................ 43

4 Applying Digital Predistortion............................................................ 46
4.1 Required Options........................................................................................................ 46

4.2 About Digital Predistortion........................................................................................ 46



ContentsR&S®SMW-K540, R&S®SMW-K541

4User Manual 1176.9506.02 ─ 07

4.2.1 Defining the Power Level of the Generated Signal....................................................... 47

4.2.2 Defining the Correction Values..................................................................................... 48

4.2.2.1 Polynomial Function......................................................................................................48

4.2.2.2 Shaping Table............................................................................................................... 49

4.2.2.3 Normalized Data........................................................................................................... 50

4.2.2.4 Predistortion Function in Raw Data Format.................................................................. 51

4.2.3 Finding Out the Correction Values................................................................................ 52

4.3 Digital Predistortions AM/AM and AM/PM Settings................................................. 53

4.3.1 General Settings........................................................................................................... 53

4.3.2 Predistortion Settings.................................................................................................... 56

4.3.3 Edit Predistortion Table Settings...................................................................................60

4.3.4 Polynomial Coefficients Settings...................................................................................62

4.3.5 Normalized Data Settings............................................................................................. 66

4.4 Compensating Non-liner RF Effects..........................................................................67

5 How to Generate a Control Signal for Power Amplifier Envelope
Tracking Tests......................................................................................70

6 How to Apply a Digital Predistortion to Improve the Efficiency of RF
Power Amplifiers..................................................................................74

7 Remote-Control Commands............................................................... 80
7.1 SOURce:IQ:OUTPut Subsystem................................................................................ 81

7.2 SOURce:IQ:OUTPut:ENVelope Commands..............................................................83

7.3 SOURce:IQ:DPD Subsystem......................................................................................99

List of Commands..............................................................................114

Index....................................................................................................117



PrefaceR&S®SMW-K540, R&S®SMW-K541

5User Manual 1176.9506.02 ─ 07

1 Preface

1.1 About this Manual

This User Manual provides all the information specific to the options R&S SMW-
K540/-K541. All general instrument functions and settings common to all applications
and operating modes are described in the main R&S SMW user manual.

The main focus in this manual is on the provided settings and the tasks required to
generate a signal. The following topics are included:
● Welcome to the Envelope Tracking and Digital Predistortion options

R&S SMW-K540/-K541
Introduction to and getting familiar with the option

● About the Envelope Tracking and Digital Predistortion
Background information on basic terms and principles in the context of the signal
generation

● Configuration and Settings
A concise description of all functions and settings available to configure signal gen-
eration with their corresponding remote control command

● How to Generate a Signal with the R&S SMW-K540/-K541 Options
The basic procedure to perform signal generation tasks and step-by-step instruc-
tions for more complex tasks or alternative methods
As well as detailed examples to guide you through typical signal generation sce-
narios and allow you to try out the application immediately

● Typical Applications/Application Examples
Example signal generation scenarios in which the option is frequently used.

● Remote Control Commands
Remote commands required to configure and perform signal generation in a
remote environment, sorted by tasks
(Commands required to set up the instrument or to perform common tasks on the
instrument are provided in the R&S SMW user manual)
Programming examples demonstrate the use of many commands and can usually
be executed directly for test purposes

● List of remote commands
Alphabetical list of all remote commands described in the manual

● Index

1.2 Documentation Overview

The user documentation for the R&S SMW consists of the following parts:
● Getting started, printed manual
● Online help system on the instrument, incl. tutorials
● User manuals and online manual, see the product page

 

 

 

Documentation Overview
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● Service manual, provided on the internet for registrated users
● Instrument security procedures, see the product page
● General safety instructions, printed brochure
● Release notes, see the product page (download > firmware)
● Data sheet and brochures, see the product page (download > brochures and data

sheets)
● Application notes, provided on the internet

You find the user documentation on the R&S SMW product page mainly at:
http://www.rohde-schwarz.com/product/SMW200A.html > "Downloads" > "Manuals"
Additional download paths are stated directly in the following abstracts of the docu-
mentation types.

Getting Started

Introduces the R&S SMW and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc.

Online Help and Tutorials

The online help offers quick, context-sensitive access to the information needed for
operation and programming. It contains the description for the base unit and the soft-
ware options.

The tutorials offer guided examples and demonstrations on operating the R&S SMW.

User Manual and Online Manual

Separate manuals are provided for the base unit and the software options:
● Base unit manual

Contains the description of the graphical user interface, an introduction to remote
control, the description of all SCPI remote control commands, programming exam-
ples, and information on maintenance, instrument interfaces and error messages.
Includes the contents of the getting started manual.

● Software option manuals
Describe the specific functions of an option. Basic information on operating the
R&S SMW is not included.

The online manual provides the contents of the user manual for immediate display on
the internet.

Service Manual

Describes the performance test for checking the rated specifications, module replace-
ment and repair, firmware update, troubleshooting and fault elimination, and contains
mechanical drawings and spare part lists.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS).

Documentation Overview

http://www.rohde-schwarz.com/product/SMW200A.html
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Instrument Security Procedures

Deals with security issues when working with the R&S SMW in secure areas.

Data Sheets and Brochures

The data sheet contains the technical specifications of the R&S SMW. Brochures pro-
vide an overview of the instrument and deal with the specific characteristics, see http://
www.rohde-schwarz.com/product/SMW200A.html > "Download" > "Brochures and
Data Sheets".

General Safety Instructions

Contains basic safety instructions in English, Spanish, German and French.

Release Notes

Describes the firmware installation, new and modified features and fixed issues
according to the current firmware version. You find the latest version at:

http://www.rohde-schwarz.com/product/SMW200A.html > "Downloads" > "Firmware"

Application Notes, Application Cards, White Papers, etc.

These documents deal with special applications or background information on particu-
lar topics, see http://www.rohde-schwarz.com/appnotes.

1.3 Conventions Used in the Documentation

1.3.1 Typographical Conventions

The following text markers are used throughout this documentation:

Convention Description

"Graphical user interface ele-
ments"

All names of graphical user interface elements on the screen, such as
dialog boxes, menus, options, buttons, and softkeys are enclosed by
quotation marks.

KEYS Key names are written in capital letters.

File names, commands,
program code

File names, commands, coding samples and screen output are distin-
guished by their font.

Input Input to be entered by the user is displayed in italics.

Links Links that you can click are displayed in blue font.

"References" References to other parts of the documentation are enclosed by quota-
tion marks.
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1.3.2 Conventions for Procedure Descriptions

When describing how to operate the instrument, several alternative methods may be
available to perform the same task. In this case, the procedure using the touchscreen
is described. Any elements that can be activated by touching can also be clicked using
an additionally connected mouse. The alternative procedure using the keys on the
instrument or the on-screen keyboard is only described if it deviates from the standard
operating procedures.

The term "select" may refer to any of the described methods, i.e. using a finger on the
touchscreen, a mouse pointer in the display, or a key on the instrument or on a key-
board.

1.3.3 Notes on Screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as much as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic test situations.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

 

 

Conventions Used in the Documentation
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2 Welcome to the R&S SMW-K540/-K541
Options
The R&S SMW-K540 is a software option that allows you to generate an envelope
tracking signal, that follows the envelope variation of the RF signal.

R&S SMW-K540 key features

● Baseband signal, RF signal, and envelope signal generation out of one instrument
● Envelope signal derived directly and in real time from the baseband signal
● Fully synchronous envelope and RF signal with optional delay compensation for

time alignment of the envelope signal
● Simultaneous output of envelope and inverted envelope signal
● Flexible envelope shaping based on different algorithms incl. a build-in table shap-

ing editor
● Import/export interface for files describing shaping functions
● Real-time display of the characteristics of the envelope signal

The R&S SMW-K541 is a software option that adds functionality to define and apply
AM/AM and AM/PM predistortions.

R&S SMW-K541 key features

● Applying user-defined AM/AM and AM/PM digital predistortions directly on the digi-
tal baseband signal

● Digital predistortions are applied directly and in real time to the baseband signal,
i.e. to any Digital Standard signal or with ARB waveforms

● Separate or superimposed AM/AM or AM/PM predistortion also with variable order
in the processing flow

● Flexible shaping of the predistortion functions based on a polynomial function and
a build-in table editor

● Import/export interface for files describing the predistortion functions, i.e. load of
AM/AM and AM/PM tables directly from characterization software

● Real-time display of the correction functions
● In instruments equipped with the option R&S SMW-K540, digitally predistorted

baseband signal, RF signal, and envelope signal generation out of one instrument

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMW user manual. The latest version is available at the
R&S SMW product page >"Downloads" > "Manuals".

 

http://www.rohde-schwarz.com/product/SMW200A.html


Welcome to the R&S SMW-K540/-K541 OptionsR&S®SMW-K540, R&S®SMW-K541

10User Manual 1176.9506.02 ─ 07

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMW Service Manual.

2.1 Accessing the Required Settings

To open the dialog with Envelope Tracking settings

1. In the block diagram of the R&S SMW, select the I/Q OUT 1/2 connector to unfold
the "I/Q Analog" block.

A dialog box opens that displays the provided general settings.

2. Select "I/Q Analog > I/Q Analog Settings > General".

3. Select "RF Envelope > On".

To open the dialog with DPD settings

► In the block diagram of the R&S SMW, select "I/Q Mod > Digital Predistortion >
AM/AM AM/PM".

A dialog box opens that displays the provided settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State > On".

2.2 Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.
In particular, this includes:
● Managing settings and data lists, like storing and loading settings, creating and

accessing data lists, or accessing files in a particular directory.
● Information on regular trigger, marker and clock signals, and filter settings, if appro-

priate.
● General instrument configuration, such as checking the system configuration, con-

figuring networks and remote operation
● Using the common status registers

For a description of such tasks, see the R&S SMW user manual.

 

 

Scope
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3 Generation of Envelope Tracking Signals
The envelope tracking (ET) is a method used by modern power amplifiers (PA) to
improve their efficiency, especially when they amplify RF signals with a high peak to
average power (PAPR). An envelope tracking detector "tracks" the power variations in
the input signal of the PA; the PA then varies synchronously to this variation the supply
voltage vcc at its end amplifying stage.

This section introduces the concept of the envelope tracking functionality and the way
it is implemented in the R&S SMW.

Refer to Chapter 5, "How to Generate a Control Signal for Power Amplifier Envelope
Tracking Tests", on page 70 for step-by-step instruction on how to use the provided
function.

3.1 Required Options

The equipment layout for generation and output of envelope tracking signal includes:
● Option Baseband Generator (R&S SMW-B10) per signal path and

Option Baseband main module, one/two I/Q paths to RF (R&S SMW-B13/B13T)
Incl. output the baseband signal at the single ended outputs

● Option Differential Analog I/Q Outputs (R&S SMW-K16) per signal path
● Option Envelope Tracking (R&S SMW-K540) per signal path
● Optional option AM/AM AM/PM Predistortion (R&S SMW-K541) per signal path

3.2 About the Envelope Tracking

Provided the required options are installed, the R&S SMW allows you to generate an
envelope tracking signal, that follows the envelope variation of the RF signal.

Principle of the envelope tracking

The Figure 3-1 shows a simplified test setup for testing of a PA with an envelope track-
ing. This illustration is intended to explain the principle in general, not all connections
and required equipment are considered.

 

 

 

About the Envelope Tracking
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Figure 3-1: Simplified test setup for power amplifier envelope tracking tests

The R&S SMW in this setup is configured to generate both, an RF signal with complex
modulation scheme and an envelope signal, that follows the envelope variation of this
RF signal. A suitable test signal is for example an EUTRA/LTE DL signal.

The R&S SMW generates the envelope signal directly from the baseband signal. The
envelope signal is a voltage signal, with voltage level Vout proportional to the power of
the RF signal (√[I(t)2+Q(t)2]) of the corresponding path. If you do not apply a shaping
function, the envelope signal follows the variation of the envelope of the RF signal line-
arly dependent.

The envelope signal is output at the I OUT and I BAR OUT rear panel connectors. This
envelope signal is then further fed to an external DC modulator.

The PA receives the RF input signal and the dynamically adapted supply voltage vcc.
Ideally, the PA gain should stay constant.

Suitable baseband signal to observe the effect of the envelope tracking settings

To simplify the explanation in the following sections, we use a simple ramp function as
a baseband signal modulated on the RF carrier.

Other suitable baseband signals are signals with relative constant envelope. You find a
choice of predefined signals in the "Baseband > Custom Dig Mod" dialog. For instance,
with the default settings in this dialog ("Custom Dig Mod > Set acc. to the standard >
GSM"), you can observe the generated envelope signal and the effects of enabled
shaping.

3.2.1 Envelope Voltage Adaptation Modes

In the R&S SMW, you define the voltage of the generated envelope signal using one of
the following modes:
● Auto Power/Normilized Envelope Voltage Adaptation:

In this mode, you define the desired input characteristics of the power amplifier.

 

About the Envelope Tracking
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Based on these values and depending on the crest factor of the currently gener-
ated signal, the R&S SMW calculates:
– The voltage on the I OUT/I BAR OUT connectors (VoutMin/Max) and a bias

(Bias),
– The RMS level of the RF signal

The auto voltage adaptation mode is a suitable choice, if you have knowledge on
the power amplifier components and characteristics, like for example the supply
voltage Vcc, the input power PEPin required for working in the linear range, as well
as the gain characteristics of the external DC modulator.
You find the required values in the documentation of your power amplifier, for
example in its data sheet.

● Manual Envelope Voltage Adaptation:
In this mode, you can additionally define the operating range of the power amplifier
based on a pre-gain and a post-gain range. Based on these values, the instrument
calculates the supply voltage Vcc.

All modes support envelope shaping.

3.2.2 Signal Parameters for Testing According to the eTrak® Specifica-
tion

In the R&S SMW, you can select one of the predefined eTrak® interface types so that
the generated signal is conform with the MIPI®Alliance specification "Analog Reference
Interface for Envelope Tracking Specification".

Table 3-1: Default parameters per eTrak® Interface Type

Parameter 1.2 Vpp 1.5 Vpp 2 Vpp

I/Q output Type Differential Differential Differential

Bias 500 mV 600 mV 900 mV

Vpp Max 1.2 V 1.5 V 2 V

Vcc Max 1.2 V 1.5 V 2 V

Bipolar Input On On On

3.2.3 Envelope Shaping and Shaping Methods

Envelope shaping is a method that uses functions to describe the relationship between
supply voltage and RF input power. An envelope shaping function is a trade-off
between effectivity and improved linearity of the PA.

In the R&S SMW, you can select the way you define the shaping function. You can
choose between:
● 2 predefined simple linear functions

(see Chapter 3.2.3.1, "About the Linear Functions", on page 14)
● 3 detroughing functions with a configurable factor

(see Chapter 3.2.3.2, "About the Detroughing Function", on page 15)
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● A polynomial function with up to 10 polynomial coefficients
(see Chapter 3.2.3.3, "About the Polynomial Function", on page 15)

● A shaping function defined as a shaping table
(see Chapter 3.2.3.4, "About the Shaping Table", on page 16)

● To set the correction values in raw format with a single remote control command
(see Chapter 3.2.3.5, "Shaping Function in Raw Data Format", on page 17)

The linear, the detroughing and the polynomial shaping functions are mathematical
expressions that are described as function of the variable x, see Table 3-2.

Table 3-2: Definition of the variable x depending on the envelope voltage adaptation mode

"Envelope Voltage Adaptation" x

Auto Power x = Vin - Vin, min

x ≥ 0

Auto Normalized x = Vin/Vin,max

Manual x = VEnv/VEnv,max

The mathematical expressions and further information on the shaping functions are
provided in the corresponding sections.

See also Chapter 3.2.3.6, "Converting Shaping Functions and Understanding the Dis-
played Values", on page 17.

● About the Linear Functions..................................................................................... 14
● About the Detroughing Function............................................................................. 15
● About the Polynomial Function............................................................................... 15
● About the Shaping Table.........................................................................................16
● Shaping Function in Raw Data Format................................................................... 17
● Converting Shaping Functions and Understanding the Displayed Values..............17

3.2.3.1 About the Linear Functions

The linear shaping can be used for less demanding applications, simple analysis, and
the first interactions by designing the optimum envelope shape. Because the shaping
gain of the linear function is 0 dB, in "Envelope Voltage Adaptation > Manual" mode
this function is suitable for determining the "Pre-/Post-Gain" values (see Example "Cal-
culating the current VCC in "Manual" mode" on page 21).

Provided are two linear functions, where each of them depends on the "Envelope Volt-
age Adaptation" mode:
● Linear (Voltage)

– f(x) = x in "Auto Normalized/Manual"
– f(x) = b*x + Vcc,min in "Auto Power"

● Linear (Power)
– f(x) = x2 in "Auto Normalized/Manual"
– f(x) = b*x2 + Vcc,min in "Auto Power"
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Where:
● the variable x depends on the "Envelope Voltage Adaptation" mode, see Table 3-2.
● The constant b is calculated as:

b = (Vcc,max - Vcc,min)/(Vin,max - Vin,min)

See also Chapter 3.2.3.6, "Converting Shaping Functions and Understanding the Dis-
played Values", on page 17.

3.2.3.2 About the Detroughing Function

Detroughing functions are well-defined mathematical functions that prevent that the
supply voltage Vcc drops down to zero or falls under specified limits. That is, they pre-
vent that the signal is clipped.

Provided are the following functions:
● f(x) = x + d*e-x/d

● f(x) = 1 - (1 - d)*cos(x*pi/2)
● f(x) = d + (1 - d)*xa

Where:
● x is a variable, that depends on the "Envelope Voltage Adaptation" mode, see

Table 3-2
● a is the Exponent (a)
● d is the Detroughing Factor (d), that limit the supply voltage Vcc in the low-power

region and controls the shaping.
The detroughing factor (d) can be set manually or derived from the selected Vcc

value. In the latter case, it is calculated as follows:
d = Vcc,min/Vcc,max

See Couple Detroughing Factor with Vcc.
A "Detroughing Factor = 0" defines a linear function.

See also Chapter 3.2.3.6, "Converting Shaping Functions and Understanding the Dis-
played Values", on page 17.

3.2.3.3 About the Polynomial Function

The polynomial function is an analytical method to describe a shaping function. The
polynomial function is defined as follows:

f(x) = a0 + ∑(an*xn), where n ≤10 and:

● Depending on the "Envelope Voltage Adaptation" mode, f(x) is:
– f(x) = Vcc(x) in "Auto Power"

– f(x) = Vcc/Vcc,max(x) in "Auto Normalized/Manual"

● The polynomial order n, the polynomial constant a0, and polynomial coefficients a0
to an are user-definable, see Chapter 3.7, "Polynomial Coefficients Setting",
on page 43

● x depends on the "Envelope Voltage Adaptation" mode, see Table 3-2
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The default polynomial function with n = 1, a0 = 0 and a0 = 1 describes a linear func-
tion.

See also
● Figure 3-13
● Chapter 3.2.3.6, "Converting Shaping Functions and Understanding the Displayed

Values", on page 17.

File format of the polynomial function file

You can store a polynomial function in a file or even define the polynomial coefficients,
store them as a file and load this file into the instrument. The polynomial files are files
with extension *.iq_poly.

The file contains an optional header # Rohde & Schwarz - IQ Output
Envelope Polynomial Coefficients # a0,a1,a2,... and a list of comma-
separated coefficient values.

Example: Polynomial function file content
# Rohde & Schwarz - IQ Output Envelope Shaping Table
# a0,a1,a2,...
0.135,0.91,0.34,-0.59,-0.11

3.2.3.4 About the Shaping Table

The envelope shaping table is a widely used method to define the shaping function.
This kind of definition is suitable if you have knowledge on or aim to achieve an exact
relation between supply voltage and RF input power. For example, with suitable set-
tings, the shaping table can precisely describe the transition region of the PA.

You can receive information on suitable envelope shaping values form the power
amplifier manufacturer.

In the R&S SMW, there are two ways to define a shaping table function:
● Externally

Create a shaping table file as a CSV file with Microsoft Excel, with a Notepad or a
similar tool, save it with the predefined extension, transfer it to and load it into the
instrument.
See also "File format of the shaping table file" on page 16.

● Internally
Use the built-in editor table editor, see Chapter 3.6, "Edit I/Q Envelope Shape Set-
tings", on page 41.

File format of the shaping table file

The shaping table files are files with predefined extension and simple file format, see
Table 3-3.
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Table 3-3: Shaping table files: format and extensions

"Envelope Voltage Adaptation" File extension Header (optional)

Auto Power *.iq_lutpv # Rohde & Schwarz - IQ Output
Envelope Shaping Table
# Power[dBm],Vcc[V]

Auto Normalized/Manual *.iq_lut # Rohde & Schwarz - IQ Output
Envelope Shaping Table
# Vin/Vmax,Vcc/Vmax

The header is optional. The file content is list of up to 4000 comma-separated value
pairs; a new line indicator separates the pairs.

Example: Shaping table file content (*.iq_lut file)
# Rohde & Schwarz - IQ Output Envelope Shaping Table
# Vin/Vmax,Vcc/Vmax
0.3,0.4
0.35,0.45
0.56,0.55
0.4,0.5
0.6,0.65
0,0.135

3.2.3.5 Shaping Function in Raw Data Format

The shaping values are defined directly, with a single remote control command. You
define the up to 4000 comma-separated value pairs, describing the
Vin/Vmax,Vcc/Vmax or Power[dBm],Vcc[V].

Example: 
SOURce1:OUTPut:ANALog:ENVelope:SHAPing:PV:FILE:DATA 0,0, 0.1,0.2, 1,1

See:
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA

on page 96
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:

DATA on page 96
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW

on page 96
● [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:NEW

on page 96

3.2.3.6 Converting Shaping Functions and Understanding the Displayed Values

If an envelope function is defined, the "Shaping" dialog displays the diagram of the
resulting envelope shape (see for example Figure 3-7).

 

 

About the Envelope Tracking



Generation of Envelope Tracking SignalsR&S®SMW-K540, R&S®SMW-K541

18User Manual 1176.9506.02 ─ 07

Several parameters influence the displayed information:
● The selected "Envelope Voltage Adaptation" determines whether the x-axis uses

normalized or linear values
● The selected "Graphic Configuration > Scale" sets the x-axis units
● The selected VccMin/Max and PEPinMin/Max values set the borders of the clipping

areas
● The selected "Shaping" function and the parameters influence the envelope shape.

The illustration on Figure 3-2 shows how these parameters influence a linear shaping
function.

Figure 3-2: Understanding the displayed values ("Shaping > Linear (Voltage)"

Shaded area = Area where the signal is clipped and the envelope signal is held constant
1a, 1b, 2a, 2b = Vcc,min/Vcc,max and PEPinMin/Max values that set the borders of the clipping areas
Shaping = Linear (Voltage)
3a = Linear function (dashed line) in "Auto Power" mode, if Vcc,min = 0 V
3b = Linear function in "Auto Power" mode, if Vcc,min > 0 V
4a = Linear function (dashed line) in "Auto Normalized" mode, if Vcc,min = 0 V
4b = Linear function in "Auto Normalized" mode, if Vcc,min > 0 V
Vin = Operating point
VccNorm = Vcc in "Auto Normalized" mode
VccPow0 = Vcc in "Auto Power" mode and Vcc,min = 0 V
VccPow1 = Vcc in "Auto Power" mode and Vcc,min > 0 V

For information on the provided shaping functions and their formulas, see:
● Chapter 3.2.3.1, "About the Linear Functions", on page 14
● Chapter 3.2.3.2, "About the Detroughing Function", on page 15
● Chapter 3.2.3.3, "About the Polynomial Function", on page 15

About the Envelope Tracking
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The group of examples in this section uses the same linear shaping function to explain
the representation in the different voltage adaptation modes. The example explains the
displayed values and how they are calculated and converted. The same principle
applies for the other shaping methods.

Common settings

● "Envelope Voltage Adaptation > Auto Power"
● Vcc,max = 1 V

● PEPinMin = -30 dBm corresponds to Vin,min = 0.0071 V

● PEPinMax = 0 dBm corresponds to Vin,max = 0.2236 V

● Pin = -15 dBm corresponds Vin = 0.04 V

● PEP = -3.4 dB
● "Shaping > Linear (Voltage)"

"Graphic Scale > Power" "Graphic Scale > Voltage"

Example: Calculating the current VccPow0 ("Auto Power" mode, Vcc,min = 0 V)
Configuration as described in Common settings and:
● Vcc,min = 0 V
● f (x) = b*x + Vcc,min

(see Chapter 3.2.3.1, "About the Linear Functions", on page 14)

VccPow0 = [(Vcc,max - Vcc,min)/(Vin,max - Vin,min)] * (Vin - Vin,min) + Vcc,min

VccPow0 = [(1 - 0)/(0.2236 - 0.0071)]*(0.04 - 0.0071) + 0

VccPow0 = 0.151 V

About the Envelope Tracking
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Example: Calculating the current VccPow1 ("Auto Power" mode, Vcc,min > 0 V)
Configuration as described in Common settings and:
● Vcc,min = 200 mV

VccPow1 = [(Vcc,max - Vcc,min)/(Vin,max - Vin,min)] * (Vin - Vin,min) + Vcc,min

VccPow1 = [(1 - 0.2)/(0.2236 - 0.0071)]*(0.04 - 0.0071) + 0.2

VccPow1 = 0.321 V

Example: Calculating the current VccNorm ("Auto Normalized" mode)
Configuration as described in Common settings and:
● "Envelope Voltage Adaptation > Auto Normalized"
● The x-axis shows the normalized values Vin/Vin,max;

The operating point with Vin = 0.04 V corresponds to
Vin/Vin.max = 0.04 / 0.2236 = 0.178

● f (x) = x, i.e.
VccNorm = Vin/Vin,max

VccNorm = 0.178 V
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If the Vcc,min value is changed (Vcc,min > 0 V), then the following applies:

● If 0 < Vin/Vin,max ≤ Vcc,min, the signal is clipped and VccNorm = Vcc,min

● If Vin/Vin,max > Vcc,min, then VccNorm = Vin/Vin,max

For the previous example, if Vcc,min = 200 mV, that VccNorm = Vcc,min = 0.2 V.

Example: Calculating the current VCC in "Manual" mode
In "Envelope Voltage Adaptation > Manual" mode, set the parameter "Pre-Gain = PEP
= - 3.4 dB".
The displayed shaping function resembles the shaping function in "Auto Normalized"
mode; the same formulas apply, too.

You can also query the VCC values for any specified x in the supported voltage adapta-
tion mode and units.
See [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue?
on page 93.

Additional information

The described principle applies for any shaping function.
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Only if linear shaping is used, the VCCNorm can also be directly converted to VCCPow
according to the following formula:

fPow(x) = [fNorm(x) - Vin,min/Vin,max]*[(Vcc,max - Vcc,min)/(1 - Vin,min/Vin,max)]

For example, if fNorm(x) = VCCNorm = 0.178 V, fPow(x) = VccPow0 is:

VccPow0 = [0.178 - 0.0071/0.2236]*[(1 - 0)/(1 - 0.0071/0.2236)]

VccPow0 = 0.151 V

3.3 General RF Envelope Settings

To access the related settings and enable the generation of the envelope signal

1. In the block diagram, select the "I/Q OUT 1/2" connector to unfold the "I/Q Analog"
block.

2. Select "I/Q Analog > I/Q Analog Settings > General".

3. Select "RF Envelope > On".

4. Select "I/Q Output Type > Differential".

5. Select "Envelope Voltage Adaptation > Auto Power".

Figure 3-3: RF Envelope Settings (Example)
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1 = Termination and input impedance of the circuit board
2 = Voltage level measured at the circuit board
3 = Signal characteristics of the DC Modulator
4 = Signal characteristics at the inputs of the PA (see the documentation of the PA, for example its data

sheet)

The dialog displays a block diagram with parameters, necessary to configure the
envelope signal.

State..............................................................................................................................23
Set to Default................................................................................................................ 23
Save/Recall................................................................................................................... 24
RF Envelope................................................................................................................. 24
Envelope Voltage Adaptation........................................................................................24
eTrak® Interface Type................................................................................................... 25
Envelope Voltage Reference........................................................................................ 25
I/Q Output Type.............................................................................................................25
VoutMin/Max...................................................................................................................25
Bias............................................................................................................................... 26
Offset.............................................................................................................................26
DC Modulator characteristics........................................................................................ 27

└ EMF................................................................................................................ 27
└ Rin................................................................................................................... 27
└ Termination.....................................................................................................27
└ Bipolar Input....................................................................................................28
└ VppMax............................................................................................................ 29
└ Gain................................................................................................................ 29
└ VccOffset..........................................................................................................29

PA characteristics......................................................................................................... 29
└ VccMin/Max......................................................................................................30
└ Power Offset................................................................................................... 30
└ PEPinMin/Max................................................................................................. 30

State
Enables/disables the analog I/Q output.

Note: By default, these output connectors are deactivated.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe on page 81

Set to Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

"State" Not affected by the "Set to Default"

"RF Envelope" Off

"I/Q Output Type" Single Ended

General RF Envelope Settings
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Parameter Value

"I/Q Level Vp (EMF)" 1 V

"Bias (EMF)" 0 V

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet on page 81

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for storing
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The file name and the directory, in which the settings are stored, are user-definable;
the file extension is however predefined.

See also, chapter "File and Data Management" in the R&S SMW user manual.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog? on page 81
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe on page 82
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD on page 82
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete on page 82

RF Envelope
In instruments equipped with option R&S SMW-K540, enables the output of a control
signal that follows the RF envelope. This control signal is provided for power amplifiers
envelope tracking testing. The signal is output at the I OUT and I BAR OUT connec-
tors.

See:
● Chapter 3, "Generation of Envelope Tracking Signals", on page 11
● Chapter 5, "How to Generate a Control Signal for Power Amplifier Envelope Track-

ing Tests", on page 70

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:STATe on page 87

Envelope Voltage Adaptation
In instruments equipped with option R&S SMW-K540, defines the way you configure
the voltage of the envelope tracking generator (see Chapter 3.2.1, "Envelope Voltage
Adaptation Modes", on page 12).

"Auto Normalized"
Generation based on the physical characteristics of the power ampli-
fier; the power values are normalized based on the selected PEPin
Max value.
This mode enables you to use the complete range of a selected
detroughing function.
See also Shaping Settings and compare the values on the X axis on
the graphical display.

General RF Envelope Settings



Generation of Envelope Tracking SignalsR&S®SMW-K540, R&S®SMW-K541

25User Manual 1176.9506.02 ─ 07

"Auto Power" Generation based on the physical characteristics of the power ampli-
fier, where the input power of the PA "PEPin" is defined with its min
and max values.

"Manual" Generation, in that the operating range of the amplifier is defined
based on a pre-gain and a post-gain range.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ADAPtion on page 87

eTrak® Interface Type
Selects one of the predefined interface types or allows user-defined settings.

See Chapter 3.2.2, "Signal Parameters for Testing According to the eTrak® Specifica-
tion", on page 13.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ETRak on page 88

Envelope Voltage Reference
Defines whether the envelope voltage Vout is set directly or it is estimated from the
selected supply voltage Vcc.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VREF on page 88

I/Q Output Type
Selects the type of output signal.

The provided parameters in the dialog depend on the selected output mode.

"Differential" ● If "RF Envelope > On"
The inverted envelope signal E BAR is output at the I BAR OUT
connectors.

● If "RF Envelope > Off"
The analog I/Q signal components are output at the I/Q BAR OUT
connectors.

"Single Ended" ● If "RF Envelope > On"
The envelope signal E is output at the I OUT connectors.

● If "RF Envelope > Off"
Single ended output at the I/Q OUT connectors.

You can define a bias between the output signal and ground.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE on page 82

VoutMin/Max
Sets or displays the minimum and maximum values of the peak-to-peak voltage Vout

voltage on the interface between the circuit board and the DC modulator.

To measure the Vout voltage:
● Use a suitable probe, i.e. use a differential probe if a "Wire to Wire" termination is

used and a single ended probe otherwise
● Measure at the circuit board after the termination impedance Rin.
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If estimated, the "VoutMin/Max" values are calculated based on the selected supply volt-
age VccMin/Max and enabled Gain and VccOffset in the DC modulator.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MIN on page 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MAX on page 89

Bias
If a bias is enabled, a DC voltage is superimposed upon the envelope signal E and the
inverted envelope signal E BAR.

"I/Q Output Type" Termination "Bias" defines

Single Ended - The bias between the envelope signal E and ground

Differential "To Ground" Superimposed DC voltage = "Bias", where "Bias" is
related to the selected Rin.

See also Table 3-4

 "Wire To Wire" Superimposed DC voltage = "Bias", where "Bias" is
related to high impedance (1 MΩ).

Table 3-4: Effect of enabled bias

Effect of a positive bias Effect of a negative bias

Use this parameter to define the operating point of a DUT.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BIAS on page 89

Offset
Sets an offset between the envelope and the inverted envelope signal.

The value range is dynamically adjusted.

The selected offset is set half in the positive and half in the negative direction.
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Table 3-5: Effect of an enabled envelope offset

Effect of a positive envelope offset Effect of a negative envelope offset

See also "VccOffset" on page 29.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:OFFSet on page 89

DC Modulator characteristics
Refer to the product documentation of the external DC modulator for information on its
characteristics.

The following settings are required:

EMF ← DC Modulator characteristics
Defines whether the EMF or the voltage value is displayed.

An EMF-based calculation assumes an open-end circuit. Disable this parameter for
testing in more realistic conditions, where you define the input impedance of the used
external DC modulator Rin and the instrument calculates the envelope output voltage
VoutMin/Max based on it.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:EMF[:STATe] on page 90

Rin ← DC Modulator characteristics
With disabled parameter EMF, sets the input impedance Rin of the used external DC
modulator.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:RIN on page 90

Termination ← DC Modulator characteristics
If the "I/Q Output Type > Differential", defines the way the inputs of the DC modulator
are terminated.
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"To Ground" "Wire to Wire"

*) Bias = 0 and Offset = 0 *) Bias = 0 and Offset = 0

Both inputs of the DC modulator are terminated to
ground.

This termination is also referred as a common mode
voltage.

The termination influences the way an enabled Bias is applied.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:TERMination on page 90

Bipolar Input ← DC Modulator characteristics
If the "I/Q Output Type > Differential", enables the instrument to generate a bipolar sig-
nal.

The envelope signal E swings above and below the inverted envelope signal E BAR;
the R&S SMW calculates and applies a suitable envelope Offset automatically, see
Figure 3-4.

Figure 3-4: Effect of a "Bipolar Input > On"

This parameter influences the lower limit of the supply voltage Vcc.

The generated signal is conform with the MIPI®Alliance specification "Specification for
Analog Reference Interface for Envelope Tracking".
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Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BINPut on page 91

VppMax ← DC Modulator characteristics
Sets the maximum value of the peak-to-peak driving voltage Vpp of the used external
DC modulator.

The Vpp limits:
● The value range of the supply voltage VccMin/Max

Vpp ≥ VCCMax
● In I/Q Output Type > Differential, the voltage of the generated envelope signal

VoutMin/Max as follows:
Vpp ≥ VoutMax[E] - VoutMax[E BAR], where [E] and [E BAR] refer to the envelope
signal and the inverted envelope signal.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VPP[:MAX] on page 90

Gain ← DC Modulator characteristics
Sets the gain of the used external DC modulator.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:GAIN on page 91

VccOffset ← DC Modulator characteristics
Applies a voltage offset on the supply voltage VccMin/Max, i.e. compensates a possible
offset from the external DC modulator. The envelope output voltage VoutMin/Max is
reduced by this value to maintain the supply voltage Vcc in the defined value range.

Figure 3-5: Effect of a Vcc offset

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet on page 91

PA characteristics
Refer to the product documentation of the PA for information on its characteristics.

The following settings are required:
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VccMin/Max ← PA characteristics
Sets or displays the minimum and maximum values of the supply voltage Vcc, as
required by the used power amplifier (PA).

The value range of the supply voltage Vcc is determined by the allowed peak-to-peak
driving voltage Vpp of the used external DC modulator and the enabled VccOffset.

VccMax ≤ VppMax

The Vcc is calculated as follows:

Vcc = Vout*Gain + VccOffset

Example: 
Envelope Voltage Reference = Vcc

VccOffset = 0 mV

VccMax = 1 V = 0 dBV

Gain = 3 dB
VccMax [dBV] - Gain [dB] = VoutMax or

VoutMax = 0 dBV - 3 dB = -3 dBV = 0.708 V

"Bipolar Input" Value range "VccMin"

"State > On" VccMin = - 0.5*VppMax

Note: Implemented as a VccOffset, see Figure 3-4.

"State > Off" VccMin = 0 to VccMax

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MIN on page 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MAX on page 92

Power Offset ← PA characteristics
Indicates an enabled power offset, for example to compensate power attenuation
because of cable lengths.

The displayed value is applied as level offset to the generated RF signal and considers
the following settings:
● "RF > RF Level > Level > Offset"
● "RF > RF Level > UCOR"

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?
on page 94

PEPinMin/Max ← PA characteristics
Sets the minimum and maximum values of the input power PEPin, as required by the
used power amplifier (PA).

General RF Envelope Settings



Generation of Envelope Tracking SignalsR&S®SMW-K540, R&S®SMW-K541

31User Manual 1176.9506.02 ─ 07

The "PEPinMin/Max" parameters define the linear range of the PA. Refer to the product
documentation of the PA for information on the characteristics of the required input sig-
nal.

The value range corresponds to the value range of output level.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MIN on page 93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MAX on page 93

3.4 Envelope Settings

The envelope tracking is a feature that requires the additional option R&S SMW-K540.

To access the envelope settings

1. Enable the generation of envelope tracking signal, see "To access the related set-
tings and enable the generation of the envelope signal" on page 22.

2. Select "I/Q Analog Settings > Envelope Settings".

1 = Enabled Digital Predistortion
2 = Envelope detector, √[I(t)2+Q(t)2]; indication changes, depending on the Envelope Voltage

Adaptation
3a, 3b = Pre-Gain/Post-Gain (available in "Envelope Voltage Adaptation > Manual" mode
4 = Shaping state and shaping function; grey background color = deactivated shaping
5 = Enabled Envelope to RF Delay
6 = Indicates the output connectors, depending on the I/Q Output Type

The dialog displays an interactive overview diagram of the ET processing chain.
The diagram displays information on shaping state, incl. current shaping method
and setting, like gains or delay.

Tip: Hotspots for quick access. The displayed blocks are hotspots. Select one of
them to access the related function.

3. To shape the envelope signal, perform one of the following:

a) on the overview diagram, select the "Shaping" block
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b) select "I/Q Analog Settings > Shaping"

See Chapter 3.5, "Shaping Settings", on page 33.

Envelope to RF Delay................................................................................................... 32
Calculate Envelope form Predistorted Signal................................................................32

Envelope to RF Delay
Sets the time delay of the generated envelope signal relative to the corresponding RF
signal. A positive value means that the envelope signal delays relative to the RF signal
and vice versa.

1

2a

2b

Figure 3-6: Effect of enabled positive RF delay

1 = RF signal
2a, 2b = Envelope signal E and inverted envelope signal E BAR

Use this parameter to compensate possible timing delays caused by connected cables
and align the input signals at the PA to prevent unwanted effects, like memory effects
or decreased linearity.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:DELay on page 88

Calculate Envelope form Predistorted Signal
In instruments equipped with option R&S SMW-K541, enables the calculation of the
envelope signal from the original baseband signal or from the AM/AM and/or AM/FM
predistorted signal.

See also Chapter 4, "Applying Digital Predistortion", on page 46.
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Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:FDPD on page 88

3.5 Shaping Settings

The envelope tracking is a feature that requires the additional option R&S SMW-K540.

To access the shaping settings in "Envelope Voltage Adaptation > Auto Power/
Normilization" mode

1. Select "I/Q Analog > I/Q Analog Settings > General".

2. Enable "RF Envelope > On".

3. Enable "Envelope Voltage Adaptation > Auto Power/Normalization".

4. Select "I/Q Analog Settings > Shaping".

With the provided settings, you can configure the shape of the RF envelope signal.
The instrument applies the settings and calculates the shaping function. A diagram
visualizes the resulting envelope shape, as function of the selected supply voltage
Vcc and PEPin value limits, the calculated pre-gain and the estimated operating
point of the PA.

1a

1b
3b

5b

6

3

4

2b2a

5a

3a

Figure 3-7: Understanding the displayed information ("Envelope Voltage Adaptation > Auto
Power", "Shaping > Detroughing")
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1a, 1b = Indicates the values of VccMin/Max
2a = Values smaller than PEPinMin are clipped
2b = Values greater than PEPinMax are clipped
3 = Operating point; corresponds to the RF RMS power level
3a = Current RF RMS power level; an enabled "RF Level > Level Offset" is considered
3b = Current VCC

4 = Crest factor of the generated signal
5a, 5b = The values correspond to the PEP of the generated RF signal and the VCC; shaded area indi-

cates the calculated Pre-Gain
6 = Current envelope shape, defined by the detroughing function and detroughing factor

See also:
● Chapter 5, "How to Generate a Control Signal for Power Amplifier Envelope

Tracking Tests", on page 70.
● Chapter 3.2.3.6, "Converting Shaping Functions and Understanding the Dis-

played Values", on page 17.

Provided are the following settings:

Shaping......................................................................................................................... 34
Detroughing Function....................................................................................................38
Couple Detroughing Factor with Vcc.............................................................................38
Detroughing Factor (d).................................................................................................. 39
Exponent (a)..................................................................................................................39
Pre-Gain........................................................................................................................39
Post-Gain...................................................................................................................... 39
Polynomial Coefficients.................................................................................................39
Shaping Table............................................................................................................... 39
Interpolation.................................................................................................................. 40
Graphic Configuration................................................................................................... 40

└ Scale...............................................................................................................41
└ Diagram.......................................................................................................... 41

Shaping
Enables envelope shaping and selects the method to define the shaping function.

For detailed information on the shaping functions, see:
● Chapter 3.2.3, "Envelope Shaping and Shaping Methods", on page 13
● Chapter 3.2.3.6, "Converting Shaping Functions and Understanding the Displayed

Values", on page 17.
See also Chapter 5, "How to Generate a Control Signal for Power Amplifier Envelope
Tracking Tests", on page 70
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"Off" Envelope shaping is not adopted.
Previously configured values of the parameters Pre-Gain and Post-
Gain are ignored.

1

2a

2b

Figure 3-8: Generated RF, envelope and inverted envelope signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E BAR

"Linear (Voltage)/Linear (Power)"
The shaping function is simple linear function.
The linear shaping is not used in practice but can be used for less
demanding applications, simple analysis, and the first interactions by
designing the optimum envelope shape. Because the shaping gain of
the linear function is 0 dB, in "Envelope Voltage Adaptation > Manual"
mode this function is suitable for determining the "Pre-/Post-Gain"
values.
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"Detroughing" The shaping function applies a detroughing to prevent that the supply
voltage Vcc drops down to zero.
Use the Detroughing Factor (d) to limit the supply voltage Vcc in the
low-power region.

1

2a

2b

Figure 3-9: Effect of a detroughing function on the envelope and inverted enve-
lope signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E BAR

Shaping Settings



Generation of Envelope Tracking SignalsR&S®SMW-K540, R&S®SMW-K541

37User Manual 1176.9506.02 ─ 07

"From Table" The shaping function is defined by user defined value pairs in form of
a shaping table.
This shaping function is suitable if you have knowledge on or aim to
achieve an exact relation between the supply voltage and RF output
power, for example by the describing the transition region of a PA.
Select Shaping Table to access the settings.

1

2a

2b

Figure 3-10: Effect of a table shaping on the envelope and inverted envelope sig-
nal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E BAR
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"Polynomial" The shaping function is defined by a polynomial with configurable
order and coefficients.
Select Polynomial Coefficients Setting to access the settings.

1

2a

2b

Figure 3-11: Effect of a polynomial shaping on the envelope and inverted enve-
lope signal

1 = RF signal (simple ramp function)
2a, 2b = Envelope signal E and inverted envelope signal E BAR

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:MODE on page 94

Detroughing Function
Selects the mathematical function describing the detroughing.

The following functions are available:
● f(x) = x + d*e-x/d

● f(x) = 1 - (1 - d)*cos(x*pi/2)
● f(x) = d + (1 - d)*xa

where:
● x depends on the "Envelope Voltage Adaptation" mode, see Table 3-2
● d = Detroughing Factor (d)
● a = Exponent (a)
For more information, see Chapter 3.2.3.6, "Converting Shaping Functions and Under-
standing the Displayed Values", on page 17.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FUNCtion on page 98

Couple Detroughing Factor with Vcc
Enable this parameter to derive the detroughing factor (d) from the selected Vcc value.
This ensures that the minimum supply voltage Vcc does not drop under the specified
limits and the signal is not clipped.

Shaping Settings
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The detroughing factor is calculated as follows:

d = VccMin/VccMax

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
COUPling on page 98

Detroughing Factor (d)
Sets a start offset to limit the supply voltage Vcc in the low-power region.

The detroughing factor also controls the shaping. A "Detroughing Factor = 0" defines a
linear function.

See also "Couple Detroughing Factor with Vcc" on page 38.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FACTor on page 98

Exponent (a)
Sets the exponent (a) for the third detroughing function, see Detroughing Function.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
PEXPonent on page 98

Pre-Gain
In "Envelope Voltage Adaptation > Manual" mode, sets a pre-gain (i.e. an attenuation)
applied to define the operating range of the power amplifier. The pre-gain can be used
to define and test only a specific (required) part of the operating range.

In "Envelope Voltage Adaptation > Auto" mode, the value is calculated automatically as
following:

"Pre-Gain" = "Pin max" - "RF Level" + Crest Factor

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:PRE
on page 95

Post-Gain
In "Envelope Voltage Adaptation > Manual" mode, sets a post-gain to compensate the
attenuation introduced by the pre-gain and the gain of the shaping function.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:POST
on page 95

Polynomial Coefficients
Accesses a dialog to describe the envelope shape as a polynomials function, see
Chapter 3.7, "Polynomial Coefficients Setting", on page 43.

Shaping Table
Accesses the standard "Envelope Select" dialog with functions to define a new shaping
table file, select or edit an existing one.

Shaping Settings
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The shaping table files are files with predefined extension and file format, see "File for-
mat of the shaping table file" on page 16.

You can create a shaping table externally or internally.

"Select" Selects and loads an existing file

"New" Creates a file

"Edit" Access a standard built-in table editor, see Chapter 3.6, "Edit I/Q
Envelope Shape Settings", on page 41.

Remote command: 
In "Envelope Voltage Adaptation > Manual" mode:
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
on page 95
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE[:SELect]
on page 95
In "Envelope Voltage Adaptation > Auto" mode:
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:
CATalog? on page 95
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE[:
SELect] on page 95

Interpolation
Enabled in "Shaping > From Table".

An envelope shaping function defined in a table contains a limited number of value
pairs. This parameter enables a linear interpolation between the defined values to pre-
vent abrupt changes.
Table 3-6: Effect of parameter "Interpolation"

"Interpolation > Off" "Interpolation > Linear Voltage"

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:INTerp
on page 96

Graphic Configuration
Comprises setting to configure the graphical display.

Shaping Settings
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Scale ← Graphic Configuration
Determines the units, "Voltage" or "Power", used on the x and y axis.
Table 3-7: Units on the x axis

 "Scale > Power" "Scale > Voltage"

Envelope Voltage Adaptation > Auto Power Pin [dBm] Vin [V] = √Pin

Envelope Voltage Adaptation > Auto Nor-
malized

Pin/Pmax Vin/Vmax

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:SCALe
on page 94

Diagram ← Graphic Configuration
Visualizes the resulting envelope shape, as function of the selected supply voltage Vcc

and PEPin value limits, the calculated pre-gain and the estimated operating point of the
PA.

See Figure 3-7.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:LEVel?
on page 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:PEP?
on page 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue? on page 93

3.6 Edit I/Q Envelope Shape Settings

The envelope shaping table is a method to define the shaping function.

To access the internal table editor

1. Select "I/Q Analog > I/Q Analog Settings > General".

2. Enable "RF Envelope > On".

3. Select "Envelope Voltage Adaptation > Manual".

4. Select "Shaping Settings > Shaping > From Table".

5. Select "Shaping Table > Envelope Shaping File > New"

6. Enter the "File Name", e.g. MyLUT

The "Envelope Shaping File" dialog closes.
The "Shaping > Shaping Table" confirms that the newly created file is assigned.

7. Select "Shaping Table > Envelope Shaping File > Edit"

8. Define the value pairs "Vin/Vmax" and "Vcc/Vmax". The order is uncritical.
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Figure 3-12: Shaping table in "Envelope Voltage Adaptation > Manual" mode

9. Select "Save".

The instrument loads the configured values automatically and displays the shaping
function.

10. Select "Shaping Settings > Interpolation > Linear (Voltage)".

The display confirms the used interpolation.

Vin/Vmax, Vcc/Vmax / Power (dBm), Vcc (V)...............................................................42
Goto, Edit, Save As, Save.............................................................................................42
Fill Table Automatically................................................................................................. 43

Vin/Vmax, Vcc/Vmax / Power (dBm), Vcc (V)
Sets the normalized values of the value pairs.

"Vin/Vmax, Vcc/Vmax"
Value pairs in "Envelope Voltage Adaptation > Manual/Auto Normal-
ized" mode.

"Power(dBm), Vcc(V)"
Value pairs in "Envelope Voltage Adaptation > Auto Power" mode.

Remote command: 
n.a.

Goto, Edit, Save As, Save
Standard functions for editing of data lists.

Changed and unsaved values are displayed on a yellow background.

Edit I/Q Envelope Shape Settings
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Remote command: 
n.a.

Fill Table Automatically
Standard function for filling a table automatically with user-defined values.

"From / Range"
Defines the start line and number of the rows to be filled.

"Select Column to Fill"
Selects the respective value, including the unit.

"Start / End Value"
Default values corresponding to the selected column.

"Increment" Determines the step size.

"Fill" Fills the table.
Fill both columns and then save the list. Otherwise the entries are
lost.

3.7 Polynomial Coefficients Setting

The polynomial function is an analytical method to describe a shaping function.

To access the polynomial coefficients setting and define a higher-order polyno-
mial

1. Select "I/Q Analog > I/Q Analog Settings > General".

 

Polynomial Coefficients Setting
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2. Enable "RF Envelope > On".

3. Select "Shaping Settings > Shaping > Polynomial".

4. Select "Envelope Voltage Adaptation > Auto Normalized".

5. Select "Polynomial Coefficients"

Figure 3-13: Polynomial Coefficients: Understanding the displayed information

With the provided settings, you can define a polynomial function with up to 10th

order to describe the envelope shape.

6. Select "Polynomial Order = 2" (n = 2).

7. Set the constant a0 and the polynomial coefficients a1 and a2.

8. Select "Apply".

The instrument loads the configured values and displays the shaping function.

9. To store the defined shaping function:

a) Select "Save/Recall Polynomial"
b) Navigate throughout the file system and enter a "File Name", e.g. MyPolyno-

mial_2thOrder
c) Select "OK".

10. Select "Polynomial Coefficients > OK" to close the dialog.

Save/Recall Polynomial................................................................................................ 45
Polynomial Order.......................................................................................................... 45
Polynomial constant and coefficients............................................................................ 45
Apply, OK...................................................................................................................... 45
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Save/Recall Polynomial
Accesses the "Save/Recall" dialog, i.e. the standard instrument function for storing and
recalling the complete dialog-related settings in a file. The provided navigation possibil-
ities in the dialog are self-explanatory.

The file name and the directory it is stored in are user-definable; the file extension is
however predefined.

The polynomial files are files with extension *.iq_poly, see "File format of the poly-
nomial function file" on page 16.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
CATalog? on page 97
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
STORe on page 97
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
LOAD on page 97

Polynomial Order
Defines the polynomial order n, that is the number of polynomial coefficients (see
Chapter 3.2.3.3, "About the Polynomial Function", on page 15).

Select "Apply" to confirm the settings.

Remote command: 
See [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:
COEFficients on page 97

Polynomial constant and coefficients
Sets the polynomial constant a0 and the polynomial coefficients a1 to an.

The polynomial constant and coefficients influence the envelope shape.

Remote command: 
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients
on page 97

Apply, OK
Triggers the instrument to adopt the selected function.

Use "OK" to apply the setting and exits the dialog.

Remote command: 
See [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:
COEFficients on page 97

Polynomial Coefficients Setting
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4 Applying Digital Predistortion
Digital predistortion (DPD) is one of the methods, used to improve the efficiency of RF
power amplifiers. In the R&S SMW, the generated digital signal can be deliberately
AM/AM and AM/PM predistorted.

4.1 Required Options

The equipment layout for digital predistortion includes:
● Option Baseband Generator (R&S SMW-B10) per signal path
● Option Frequency (R&S SMW-B1xx/B2xx)
● Option Baseband main module, one/two I/Q paths to RF (R&S SMW-B13/B13T)
● Option AM/AM AM/PM Predistortion (R&S SMW-K541) per signal path
● Optional option Envelope Tracking (R&S SMW-K540) per signal path

4.2 About Digital Predistortion

Power amplifiers are an essential part of any telecommunication systems. While
amplify the transmitted signal, power amplifiers may also distort this signal and change
its amplitude and/or phase characteristics. Such distortions result in undesired effects
like spectrum regrowth, harmonic generation, intermodulation (IM) products, or
increased bit error rate.

The principle of the digital predistortion

To compensate for the distortions caused by the transmission system, the signal is
deliberately digitally predistorted. Digital predistortion (DPD) is a method to apply wan-
ted and well-defined predistortion on the signal to be transmitted so that when this sig-
nal is amplified, the resulting signal features the identical characteristics, as the initial
signal before the predistortion.

Pin

Pout

Pin

Pout

PA
Pin Pout

DPD

a b c

signal

Figure 4-1: Illustration of predistortion principle
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DPD = digital predistortion
PA = power amplifier
a = predistortion function
b = characteristic of the power amplifier, for example the non-linear input power vs. output power

(AM/AM) function
c = ideal linearized characteristic of the amplified signal

Digital predistortion models

When testing power amplifiers, it is important to measure and analyze signal distor-
tions.

There are several known models used to describe distortions. This implementation
focuses on the following two types of distortion:
● The AM/AM (amplitude-to-amplitude) distortion and
● The AM/PM (amplitude-to-phase) distortion.

An AM/AM representation is a standard method that shows the signal power level at
the input of the DUT against the power level at the output of the DUT. The default unit
for both axes is dBm but the AM/AM representation can also be normalized.

An AM/PM curve shows the phase difference in degrees (y-axis) for every input power
level (x-axis).

If your R&S SMW is equipped with the required option R&S SMW-K541, you can
define both, an AM/AM and an AM/PM predistortion and apply them separately or
superimposed on each other on the generated digital baseband signal.

If your instrument is equipped with the option R&S SMW-K540, you can also apply pre-
distortions on the generated envelope signal.

Refer to Chapter 3, "Generation of Envelope Tracking Signals", on page 11 for more
information.

4.2.1 Defining the Power Level of the Generated Signal

You can define the level of the generated signal in one of the following ways:
● Level Reference > Before DPD

In this mode, the "Level" parameter in the status bar of the instrument defines the
signal level before the DPD is applied.
Signal with selected level is pre-distorted and depending on the selected AM/AM
and AM/PM functions, attenuated or boosted.
See Table 4-1.

● Level Reference > After DPD
In this mode, you define the resulting signal level. Based on this value and depend-
ing on current predistortion function, the R&S SMW calculates the level of the sig-
nal to be pre-distorted.
The level calculation requires several interaction cycles; the number of iterations is
a trade-off between level accuracy and speed.
See "To perform manual iterations to achieve a desired resulting signal level after
the DPD" on page 76 for explanation of how the interactions are performed.

 

About Digital Predistortion



Applying Digital PredistortionR&S®SMW-K540, R&S®SMW-K541

48User Manual 1176.9506.02 ─ 07

Table 4-1: Difference between the level reference modes

"Level Reference > Before DPD" "Level Reference > After DPD"

1: "LevelIN = Level = -15 dBm", i.e. signal level before DPD

2: "PEPIN = PEP -3.43 dBm", i.e. PEP of the signal before DPD

3: "LevelOUT = -15.42 dBm", resulting signal level after DPD

4: "PEPOUT = -3.68 dBm", resulting PEP of the signal after DPD

1: "LevelOUT = Level = -15 dBm", i.e. signal level after DPD

2: "PEPOUT = PEP = -3.57 dBm", i.e. PEP of the signal after
DPD

3: "LevelIN = -15.43 dBm", calculated signal level before DPD

4: "PEPIN = -3.86 dBm", calculated of the signal before DPD

5: allowed maximum level error

6: maximum number of iteration to be used to achieve the
required level error

4.2.2 Defining the Correction Values

In the R&S SMW, you can select the way you define the predistortion function and
choose between:
● A polynomial function with up to 10 polynomial coefficients

(see Chapter 4.2.2.1, "Polynomial Function", on page 48)
● A predistortion function defined as a look-up table

(see Chapter 4.2.2.2, "Shaping Table", on page 49)
● A normalized data

(see Chapter 4.2.2.3, "Normalized Data", on page 50)
● To set the correction values in raw format with a single remote control command

(see Chapter 4.2.2.4, "Predistortion Function in Raw Data Format", on page 51).

4.2.2.1 Polynomial Function

The polynomial function is an analytical method to describe a predistortion function.
When using the polynomial function, you do not define the correction values (ΔPower
and ΔPhase) directly as it is in the look-up table, but you describe the predistortion
function and the R&S SMW derives the correction values out of it.

See Chapter 4.3.4, "Polynomial Coefficients Settings", on page 62.
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This implementation uses a polynomial with complex coefficients defined as follows:

PDPD(x) = ∑[(an+j*bn)*xn],

where:
● n = "Polynomial Order" ≤ 10
● x = Pin/PinMax

● an and bn are user-defined coefficients, defined as Cartesian (polar) or Cylindrical
coordinates.
In Cartesian coordinates system, the coefficients bn are expressed in degrees.

The R&S SMW calculates the AM/AM and AM/PM predistortion functions as follows:
● AM/AM(x) = abs[PDPD(x)]

● AM/PM(x) = tan-1{Im[PDPD(x)]/Re[PDPD(x)]}

A dedicated graphical display visualizes the resulting functions, see Figure 4-4.

The R&S SMW calculates the correction values (ΔAM/AM and ΔAM/PM functions) as
follows:
● ΔAM/AM(x) = AM/AM(x) - x = abs[PDPD(x)] -x

● ΔAM/PM(x) = AM/PM(x) = tan-1{Im[PDPD(x)]/Re[PDPD(x)]}

A dedicated graphical display visualizes the calculated correction functions, see Fig-
ure 4-5 and compare with Figure 4-4.

File format of the polynomial file

You can store a polynomial function in a file or even define the polynomial coefficients,
store them as a file and load this file into the instrument. The polynomial files are files
with the extension *.dpd_poly.

The file contains an optional header # Rohde & Schwarz - Digital
Predistortion Polynomial Coefficients # a0,b0, a1,b1, a2,b2, ...
and a list of comma-separated coefficient value pairs, stored in Cartesian coordinates.

For values above the selected Input Range (PEPin), the predistortion function assumes
a linear ratio of the input to output power.

Example: Polynomial function file content
# Rohde & Schwarz - Digital Predistortion Polynomial Coefficients
# a0,b0, a1,b1, a2,b2, ...
0,0,-0.25,0.2,0.6,-0.3,0.3,0.3,0.5,-0.4

4.2.2.2 Shaping Table

In the R&S SMW, there are two ways to define the predistortion function in form of a
shaping table:
● Externally
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Create a correction table file as a CSV file with Microsoft Excel, with a Notepad or
a similar tool, save it with the predefined extension, transfer it to and load it into the
instrument.
See also "File format of the correction table file" on page 50.

● Internally
Use the built-in editor table editor, see Chapter 4.3.3, "Edit Predistortion Table Set-
tings", on page 60.

File format of the correction table file

The correction table files are files with predefined extension and simple file format, see
Table 4-2.

Table 4-2: Shaping table files: format and extensions

Predistortion model File extension Header (optional)

AM/AM *.dpd_magn # Rohde & Schwarz - Digital AM/AM
Predistortion 
Table Pin[dBm],deltaPower[dB]

AM/PM *.dpd_phase # Rohde & Schwarz - Digital AM/PM
Predistortion 
Table Pin[dBm],deltaPhase[deg]x

The header is optional. The file content is a list of up to 4000 comma-separated value
pairs, describing the delta values for amplitude or phase related to the absolute input
power Pin; a new line indicator separates the pairs.

For values above the selected Input Range (PEPin), the predistortion function assumes
a linear ratio of the input to output power.

Example: Shaping table file content (*.dpd_magn file)
# Rohde & Schwarz - Digital AM/AM Predistortion Table
Pin[dBm],deltaPower[dBm]
-30,0.5
3,-0.01

4.2.2.3 Normalized Data

In the R&S SMW, there are two ways to define the predistortion function as normalized
data:
● Externally

We recommend that you calculate the normalized correction data by a connected
R&S®FSW equipped with R&S®FSW-K18 Power Amplifier and Envelope Tracking
Measurements option.
You can also create the correction table file as a CSV file with Microsoft Excel, with
a Notepad or a similar tool, save it with the predefined extension, transfer it to and
load it into the instrument.
See also "File format of the correction table file" on page 50.

● Internally
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Use the built-in editor table editor, see Chapter 4.3.3, "Edit Predistortion Table Set-
tings", on page 60.

File format of the normalized data

The normalized data files are files with predefined extension *.dpd_norm and simple
file format, see "File format of the normalized data" on page 51.

The file contains an optional header # Rohde & Schwarz - Digital
Predistortion Normalized Table Data # PinMax [dBm] # number of
points # Vin/Vmax, deltaV/V, deltaPhase [deg], the values of the Pinmax,
the number of the subsequent points and a list of comma-separated groups of three
values.

Example: Normalized data file content
# Rohde & Schwarz - Digital Predistortion Normalized Table Data
# PinMax [dBm]
# number of points
# Vin/Vmax, deltaV/V, deltaPhase [deg] 
10
4096
0,0,0
0.0002442,-0.00018246,0.28052
0.0004884,-0.00036487,0.28041
0.0007326,-0.00054723,0.2803
0.0009768,-0.00072954,0.28019
0.001221,-0.00091181,0.28008
0.0014652,-0.001094,0.27996
...

4.2.2.4 Predistortion Function in Raw Data Format

The predistortion values are defined directly, with a single remote control command:
● Define the up to 4000 comma-separated value pairs, describing the absolute input

power Pin and the delta values for amplitude or phase (ΔPower and ΔPhase).
Example:
SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA -30.4,-5.2,
-25.1,-4.5, -18.5,-2.5, -10.5,-1
See:
– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA

on page 108
– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA

on page 108
– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:NEW on page 107

– [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW on page 107
● Define the absolute maximum input power Pinmax, the number of subsequent

points, and the normalized values Vin/Vmax, ΔV/V, ΔPhase [deg] as binary data.
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See [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA on page 109.

4.2.3 Finding Out the Correction Values

If you know the properties of the used power amplifier, you can calculate suitable cor-
rection values.

To explain the principle, we assume that the characteristics of a power amplifier have
been measured and that the left graphic in the following table shows the AM/AM curve
of this amplifier.

Defining correction coefficients for an AM/AM predistortion
(Example)

Resulting AM/AM predistortion function (Example)

a = ideal characteristic; if the amplifier did not distort the signal,
the normalized magnitude would a line

b = measured AM/AM curve; the normalized magnitude varies
as a function of input power

a = ideal characteristic

b = measured AM/AM curve

c = resulting AM/AM predistortion function, i.e. correction values
curve

d = ideal predistorted signal

The required correction coefficient ΔPower is the difference between the ideal and the
real normalized amplitude for one particular input power. To compensate for the non-
linearity and the deviation from the ideal line, select a negative correction value (-Δ) for
any input power where the real normalized amplitude is greater than the ideal one (1).
Logically, a positive correction value (+Δ) compensates for (i.e. boost) an amplitude
that is smaller than the ideal one (2).

Ideally, a signal predistorted with a suitable function (c) and then amplified by the par-
ticular PA would have a linear characteristic (a).

In the practice, however, you do not calculate the correction coefficients manually but
they are calculated automatically. A suitable solution is the R&S®FS-K130PC software
or the R&S®FSW-K18 Power Amplifier and Envelope Tracking Measurements option,
see Chapter 6, "How to Apply a Digital Predistortion to Improve the Efficiency of RF
Power Amplifiers", on page 74.
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4.3 Digital Predistortions AM/AM and AM/PM Settings

You can add digital predistortion to the generated baseband signal and thus compen-
sate an amplitude as well as a phase distortion of the DUT, for example of the tested
power amplifier (PA).

To access the required settings

► Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM".

The dialog covers the settings for digital predistortion, like select and enabling an
AM/AM and/or AM/PM predistortion, select the way the predistortion function are
defined and specify the correction values.

The remote commands required to define these settings are described in Chapter 7.3,
"SOURce:IQ:DPD Subsystem", on page 99.

4.3.1 General Settings

State..............................................................................................................................54
Set to Default................................................................................................................ 54
Save/Recall................................................................................................................... 54
AM/AM First.................................................................................................................. 54
Level Reference............................................................................................................ 54
Maximum Output Level Error........................................................................................ 55
Maximum Number of Iteractions................................................................................... 55
Achieved Output Level Error......................................................................................... 55
Input/Output PEP, Level and Crest Factor....................................................................55
AM/AM and AM/PM State............................................................................................. 55
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State
Enables/disables the generation of digital predistorted signals.

Remote command: 
[:SOURce<hw>]:IQ:DPD:STATe on page 102

Set to Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

"State" Not affected by the "Set to Default"

"Level Reference" Before DPD

"AM/PM, AM/AM" Off

Remote command: 
[:SOURce<hw>]:IQ:DPD:PRESet on page 102

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for storing
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The file name and the directory, in which the settings are stored, are user-definable;
the file extension is however predefined.

See also, chapter "File and Data Management" in the R&S SMW user manual.

Remote command: 
[:SOURce<hw>]:IQ:DPD:SETTing:CATalog? on page 102
[:SOURce<hw>]:IQ:DPD:SETTing:STORe on page 103
[:SOURce<hw>]:IQ:DPD:SETTing:LOAD on page 103
[:SOURce<hw>]:IQ:DPD:SETTing:DELete on page 103

AM/AM First
Toggles the order the AM/AM and AM/PM predistortions are applied.

Remote command: 
[:SOURce<hw>]:IQ:DPD:AMFirst on page 103

Level Reference
Switches between dynamic and static adaptation of the range the selected DPD is
applied on.

"Before DPD/After DPD"
Selects dynamic range calculation and defines whether the selected
"Level" value corresponds to the signal level before or after the pre-
distortion, see Chapter 4.2.1, "Defining the Power Level of the Gener-
ated Signal", on page 47.

"Static DPD" Selects static (constant) range limits. To adjust the range, use the
parameter Pre-Gain.
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Remote command: 
[:SOURce<hw>]:IQ:DPD:LREFerence on page 104

Maximum Output Level Error
Sets the allowed maximum error, see Chapter 4.2.1, "Defining the Power Level of the
Generated Signal", on page 47.

Remote command: 
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX on page 104

Maximum Number of Iteractions
Sets the maximum number of performed iterations to achieving the required Maximum
Output Level Error.

See also Chapter 4.2.1, "Defining the Power Level of the Generated Signal",
on page 47.

Remote command: 
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX on page 104

Achieved Output Level Error
Displays the resulting level error, see Chapter 4.2.1, "Defining the Power Level of the
Generated Signal", on page 47.

Remote command: 
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor? on page 104

Input/Output PEP, Level and Crest Factor
Displays the calculated values the before and after the DPD

See "To perform manual iterations to achieve a desired resulting signal level after the
DPD" on page 76.

A value of -1000 indicates that the calculation is impossible or there are no measure-
ments results available.

Remote command: 
[:SOURce<hw>]:IQ:DPD:INPut:PEP? on page 105
[:SOURce<hw>]:IQ:DPD:INPut:LEVel? on page 105
[:SOURce<hw>]:IQ:DPD:INPut:CFACtor? on page 105
[:SOURce<hw>]:IQ:DPD:OUTPut:PEP? on page 105
[:SOURce<hw>]:IQ:DPD:OUTPut:LEVel? on page 105
[:SOURce<hw>]:IQ:DPD:OUTPut:CFACtor? on page 105

AM/AM and AM/PM State
Enables/disables the AM/AM and AM/PM digital predistortion.

If both predistortions are enabled simultaneously, the instrument applies the AM/AM
predistortion first and compensates the phase error of the PA afterwards.

Compare the displayed signal processing chain.

Remote command: 
[:SOURce<hw>]:IQ:DPD:AMAM:STATe on page 103
[:SOURce<hw>]:IQ:DPD:AMPM:STATe on page 103
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4.3.2 Predistortion Settings

To access the "Predistortion Settings"

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM".

2. Select "Digital Predistortion AM/AM, AM/PM > Predistortion Settings".

Figure 4-2: Predistortion Settings > From Table: Understanding the displayed information

1a = Normalized value of the current RF RMS power level
2a = Normalized value of the current PEP of the generated RF signal
1b, 2b = Correction values
white dashed line = Ideal zero correction function; no correction is necessary
yellow curve = Predistortion function
3a, 3b = Input Range (PEPin)
4 = Positive correction coefficients to compensate values below the ideal ones
5 = Values greater than the PEPin Max are ignored

The dialog covers the settings for digital predistortion, like select and enabling an
AM/AM and/or AM/PM predistortion, select the way the predistortion function is
defined and specify the correction values.

Shaping......................................................................................................................... 57
Interpolation.................................................................................................................. 57
Invert correction values................................................................................................. 57
Input Range (PEPin)...................................................................................................... 58
Pre-Gain........................................................................................................................58
Shaping Table............................................................................................................... 59
Polynomial Coefficients.................................................................................................59
Normalized Data........................................................................................................... 59
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Graphic Configuration................................................................................................... 59
└ Scale...............................................................................................................59
└ AM/AM and AM/PM Diagrams........................................................................59

Shaping
Selects the method to define the correction coefficients.

"From Table" As value pairs in form of a shaping table.
Select "AM/AM or AM/PM Shaping Table" to access the settings, see
Chapter 4.3.3, "Edit Predistortion Table Settings", on page 60

"Polynomial" By a polynomial with configurable order and coefficients.
Select "AM/AM or AM/PM Polynomial Coefficients" to access the set-
tings, see Chapter 4.3.4, "Polynomial Coefficients Settings",
on page 62.

"Normalized" As a normalized data.
Select "Normalized Data" to access the settings, see Chapter 4.3.5,
"Normalized Data Settings", on page 66.

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:MODE on page 106

Interpolation
Enabled in "Shaping > From Table/Normalized".

A predistortion function defined in a table contains a limited number of value pairs. This
parameter enables a linear interpolation between the defined values to prevent abrupt
changes.
Table 4-3: Effect of parameter "Interpolation"

"Interpolation > Off" "Interpolation > Linear (Power)"

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:INTerp on page 108

Invert correction values
Inverts the defined correction values.

Use this function to apply the exact invert predistortion coefficients without to change
the defined predistortion table.

This function is also useful to toggle between predistortions with corrections related to
the input power and to the output power.
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Table 4-4: Effect of parameter "Invert correction values"

"Invert correction values > Off" "Invert correction values > On"

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing[:TABLe]:INVert on page 108

Input Range (PEPin)
Defines the minimum and maximum input power PEPin.

If you apply digital predistortion on signals used for power amplifier tests with envelope
tracking, set the PEPinMax value to the maximum value of the input power PEPin Max,
as required by the used power amplifier (PA).

Remote command: 
[:SOURce<hw>]:IQ:DPD:PIN:MIN on page 105
[:SOURce<hw>]:IQ:DPD:PIN:MAX on page 105

Pre-Gain
In "Level Reference > Static DPD" mode, sets a pre-gain (i.e. an attenuation) to define
the range the DPD is applied in. The pre-gain can be used to define and test only a
specific (required) part of the operating range.

1 = Pre-gain limits the effective range of the shaping function
2 = Values above this limit are ignored
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In "Level Reference > Before/After DPD" mode, the range is limited by the current PEP
of the signal, see Figure 4-2.

Remote command: 
[:SOURce<hw>]:IQ:DPD:GAIN:PRE on page 106

Shaping Table
Accesses the standard "Predistortion Select" dialog with functions to define a new
shaping table file, select, or edit an existing one.

The shaping table files are files with predefined extension and file format, see "File for-
mat of the correction table file" on page 50.

You can create a shaping table externally or internally.

"Select" Selects and loads an existing file

"New" Creates a file

"Edit" Access a standard built-in table editor, see Chapter 4.3.3, "Edit Pre-
distortion Table Settings", on page 60.

Remote command: 
For AM/AM distortions:
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog? on page 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect] on page 107
For AM/PM distortions:
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog? on page 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect] on page 107

Polynomial Coefficients
Accesses a dialog to describe the predistortion function as a polynomial function, see
Chapter 4.3.4, "Polynomial Coefficients Settings", on page 62.

Normalized Data
Accesses a dialog to describe the predistortion function as a normalized data, see
Chapter 4.3.5, "Normalized Data Settings", on page 66.

Graphic Configuration
Comprises setting to configure the graphical display.

Scale ← Graphic Configuration
Determines the units, "Voltage" or "Power", used on the x-axis.

Remote command: 
[:SOURce<hw>]:IQ:DPD:SCALe on page 106

AM/AM and AM/PM Diagrams ← Graphic Configuration
Visualize the resulting AM/AM and/or AM/PM predistortion functions, as function of the
selected PEPin value limits.

See Figure 4-2.

Remote command: 
[:SOURce<hw>]:IQ:DPD:AMAM:VALue:LEVel? on page 111
[:SOURce<hw>]:IQ:DPD:AMAM:VALue:PEP? on page 111
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[:SOURce<hw>]:IQ:DPD:AMAM:VALue? on page 112
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:LEVel? on page 111
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:PEP? on page 111
[:SOURce<hw>]:IQ:DPD:AMPM:VALue? on page 112

4.3.3 Edit Predistortion Table Settings

The predistortion table is an internal editor where you define the correction values,
ΔPower and ΔPhase, in form of a look-up table.

To access the internal table editor

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM".

2. Select "Digital Predistortion AM/AM AM/PM > Predistortion Settings".

3. Select "Shaping > From Table".

4. Select "AM/AM > Shaping Table > Predistortion AM/AM Shaping File > New"

5. Enter the "File Name", e.g. My_DPD_AM-AM

The "Predistortion AM/AM Shaping File" dialog closes.
The "Shaping Table > My_DPD_AM-AM" confirms that the newly created file is
assigned.

6. Select "Shaping Table > Predistortion AM/AM Shaping File > Edit"

7. Define the value pairs "Pin/dBm" and "ΔPower/dB". The order is uncritical.

Figure 4-3: Example of an AM-AM predistortion table values

8. Select "Save".

The instrument loads the configured values automatically and displays the function
of the delta correction values.

9. Select "Predistortion Settings > Interpolation > Linear".

The display confirms the used interpolation.
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Pin (dBm), Delta Power (dB) / Pin (dBm), Delta Phase (deg).......................................61
Goto, Edit, Save As, Save.............................................................................................61
Fill Table Automatically................................................................................................. 61

Pin (dBm), Delta Power (dB) / Pin (dBm), Delta Phase (deg)
Sets the correction value pairs.

"Pin, ΔPower"
Value pairs for the AM/AM predistortion

"Pin, ΔPhase"
Value pairs for the AM/PM predistortion

Remote command: 
See [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect]
on page 107
and [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect]
on page 107

Goto, Edit, Save As, Save
Standard functions for editing of data lists.

Changed and unsaved values are displayed on a yellow background.

Remote command: 
n.a.

Fill Table Automatically
Standard function for filling a table automatically with user-defined values.
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"From / Range"
Defines the start line and number of the rows to be filled.

"Select Column to Fill"
Selects the respective value, including the unit.

"Start / End Value"
Default values corresponding to the selected column.

"Increment" Determines the step size.

"Fill" Fills the table.
Fill both columns and then save the list. Otherwise the entries are
lost.

4.3.4 Polynomial Coefficients Settings

Alternatively to the look-up table, you can define the predistortion functions as a poly-
nomial function. The R&S SMW calculates the AM/AM and AM/PM predistortion func-
tions and the required correction coefficients out of the defined polynomial.

To access the polynomial coefficients setting and define a higher-order polyno-
mial

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM".

2. Select "Digital Predistortion AM/AM AM/PM > Predistortion Settings".

3. Select "Shaping > Polynomial".

4. Select "AM/PM > Polynomial Coefficients"
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Figure 4-4: Polynomial Coefficients: Understanding the displayed information

n = Polynomial order
a0, b0, ... = Polynomial coefficients
1 = Ideal AM/AM function (the normalized amplitude is a line)
2 = Resulting AM/AM predistortion function, calculated as AM/AM(x) = abs[PDPD(x)]
3 = Ideal AM/PM function (constant phase at 0 degrees)
4 = Resulting AM/PM predistortion function, calculated as AM/PM(x) = tan-1{Im[PDPD(x)]/

Re[PDPD(x)]}

With the provided settings, you can define a polynomial function with up to 10th

order to describe the predistortion function.
The graphical display updates on-the-fly and visualize of the resulting AM/AM and
AM/PM functions.

5. Select "Polynomial Order = 4" (n = 4).

6. Set the polynomial coefficients a0 to b4.

7. Select "Apply".

The instrument loads the configured values, calculates the correction values, and
displays the predistortion functions.
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Figure 4-5: Predistortion Settings > Polynomial: Understanding the displayed information

1a = Normalized value of the current RF RMS power level
2a = Normalized value of the current PEP of the generated RF signal
1b, 2b = Correction values
white dashed line = Ideal zero function; no correction is necessary
AM/AM yellow curve = AM/AM correction values, calculated as ΔAM/AM(x) = AM/AM(x) - x
AM/PM yellow curve = AM/PM correction values, calculated as ΔAM/PM(x) = AM/PM(x)
3a, 3b = X-axis scale, calculated form the Input Range (PEPin)
4 = Negative correction coefficients
5 = Values greater than the PEPin Max are ignored

8. To store the defined predistortion function:

a) Select "Save/Recall Polynomial"
b) Navigate throughout the file system and enter a "File Name", e.g. MyPolyno-

mial_4thOrder
c) Select "OK".

9. Select "Polynomial Coefficients > OK" to close the dialog.

Save/Recall Polynomial................................................................................................ 64
System Coordinates......................................................................................................65
Polynomial Order.......................................................................................................... 65
Polynomial coefficients..................................................................................................65
Apply, OK...................................................................................................................... 65

Save/Recall Polynomial
Accesses the "Save/Recall" dialog, i.e. the standard instrument function for storing and
recalling the dialog-related settings in a file. The provided navigation possibilities in the
dialog are self-explanatory.

Digital Predistortions AM/AM and AM/PM Settings



Applying Digital PredistortionR&S®SMW-K540, R&S®SMW-K541

65User Manual 1176.9506.02 ─ 07

The file name and the directory it is stored in are user-definable; the file extension is
however predefined.

The polynomial files are files with extension *.dpd_poly, see "File format of the poly-
nomial file" on page 49. The polynomial function is stored in Cartesian format.

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?
on page 109
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD
on page 109
[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe
on page 109

System Coordinates
Defines whether the polynomial function is defined in Cylindrical (Polar) or in Cartesian
coordinates.

Remote command: 
n.a.

Polynomial Order
Defines the polynomial order n, that is the number of polynomial coefficients (see
Chapter 4.2.2.1, "Polynomial Function", on page 48).

The polynomial order defines the degree, complexity, and the number of terms in the
polynomial function.

Remote command: 
See [:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients
on page 108

Polynomial coefficients
Sets the polynomial coefficients a0 to an and b0 to bn.

In "System Coordinates > Cylindrical", the polynomial coefficients b0 to bn are
expressed in degrees.

The polynomial coefficients influence the shape of the predistortion function, see Fig-
ure 4-4 for an illustration of a polynomial function.

Select "Apply" to confirm the settings.

Remote command: 
See [:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients
on page 108

Apply, OK
Triggers the instrument to adopt the selected function.

Use "OK" to apply the setting and exits the dialog.
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Remote command: 
n.a.

4.3.5 Normalized Data Settings

The normalized data table is an internal editor where you define the correction values,
Vin/Vmax, ΔV/V and ΔPhase, in form of a table.

To access the internal editor

1. Select "I/Q Mod > Digital Predistortion > AM/AM AM/PM".

2. Select "Digital Predistortion AM/AM AM/PM > Predistortion Settings".

3. Select "Shaping > Normalized Data".

4. Select "Normalized Data".

5. Enter the Pinmax.
Note: Enter the correction values in the required order. The value range of the sub-
sequent correction values is automatically adjusted.

6. To store the setting in a file, select "Save/Recall Normalized Data > Save".
Enter a "File Name", e.g. My_DPD_Normalized.
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Save/Recall Normalized Data....................................................................................... 67
Pinmax............................................................................................................................ 67
Vin/Vmax, ΔV/V,ΔPhase (deg)......................................................................................67
Apply, OK...................................................................................................................... 67

Save/Recall Normalized Data
Accesses the "Save/Recall" dialog, i.e. the standard instrument function for storing and
recalling the dialog-related settings in a file. The provided navigation possibilities in the
dialog are self-explanatory.

The file name and the directory it is stored in are user-definable; the file extension is
however predefined.

The normalized data files are files with extension *.dpd_norm, see "File format of the
normalized data" on page 51.

Remote command: 
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:CATalog? on page 110
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:LOAD on page 110
[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:STORe on page 111

Pinmax

Sets the value of the maximum input power level.

Pinmax corresponds to a normalized input power of 1, that is the max. allowed value on
the x-axis.

Select "Apply" to confirm the settings.

Remote command: 
See [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA on page 109

Vin/Vmax, ΔV/V,ΔPhase (deg)
Sets the correction as a group of three values.

Select "Apply" to confirm the settings.

Remote command: 
See [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA on page 109

Apply, OK
Triggers the instrument to adopt the normalized data.

Use "OK" to apply the setting and exits the dialog.

Remote command: 
n.a.

4.4 Compensating Non-liner RF Effects

The R&S SMW provides a built-in function for compensating of its own non-linear RF
effects caused by the amplifiers. If the function is enabled, the instrument uses the digi-
tal predistortion function and applies automatically calculated AM/AM predistortion val-
ues to the generated baseband signal.
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The RF linearization and the "Digital Predistortions, AM/AM and AM/PM" cannot be
used simultaneously; activating the "Linearize RF" parameter disables the "Digital Pre-
distortions, AM/AM and AM/PM" settings.

To access the required settings:

1. Select "I/Q Mod > I/Q Modulator > General > Linearize RF".

2. Select "Adjust Linearization Current Frequency".

The R&S SMW calculates the required correction values for the selected RF and
the current generated signal.

Linearize RF
In instruments equipped with option R&S SMW-K541, enables an automatic AM/AM
predistortion of the non-linear RF chain.
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During RF linearization, the "Digital Predistortions AM/AM and AM/PM" settings are
disabled.

Remote command: 
[:SOURce<hw>]:IQ:DPD:LRF:STATe on page 112

Adjust Linearization Current Frequency
The correction data is calculated for the currently selected frequency.

During RF linearization, the "Digital Predistortions AM/AM and AM/PM" settings are
disabled.

Remote command: 
[:SOURce<hw>]:IQ:DPD:LRF:ADJust? on page 113

Compensating Non-liner RF Effects
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5 How to Generate a Control Signal for Power
Amplifier Envelope Tracking Tests
Refer to Figure 3-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking. The illustration is intended to explain the principle in general,
not all connections and required equipment are considered.

The R&S SMW in this setup is configured to generate an LTE RF signal with complex
modulation scheme and high peak to average power (PAPR), and the required enve-
lope signal. A polynomial shaping function is defined.

The PA receives the RF input signal and the dynamically adapted supply voltage. Ide-
ally, the gain of the PA should stay constant.

Required are the following values:
● Characteristics of the power amplifier: supply voltage VCC, the input power PEPin

● Characteristics of the external DC modulator: gain, peak-to-peak voltage VPP, input
impedance Rin

To configure the R&S SMW to generate the RF and RF envelope signal

1. Enable the R&S SMW to generate an EUTRA/LTE FDD DL signal.
Select "Baseband > EUTRA/LTE" and enable for example:

a) Select "Link Direction > Downlink"
b) Select "Test Model > E-TM1_1--5MHZ"
c) Enable "State > On"

2. Set "Frequency = 2.143 GHz" and "Level = -15 dB"

3. In the block diagram, select "I/Q Out > I/Q Analog > I/Q Analog Outputs > General"
and perform the following:

a) Select "RF Envelope > On".
b) Select "Envelope Voltage Adaptation > Auto Power"
c) Select "I/Q Output Type > Differential"
d) Configure the settings as shown on Figure 3-3.
e) Select "I/Q Analog Outputs > Envelope Settings" and set for example "Enve-

lope to RF Delay = 10 ps"
f) Select "I/Q Analog Outputs > Shaping > Shape > Detroughing".
g) Set "Detroughing Function = 1: f(x) = x + d*e(-x/d)".
h) Set "Detroughing Factor (d) > Coupled with Vcc = On".
i) Select "Graphic Configuration > Scale > Power".
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1a, 1b = VCCmin = 0.5 V, VCCmax = 2.5 V
2a, 2b = Pinmin = -30 dBm, Pinmax = 0 dBm
3 = RF Level = -15 dBm (operating point)
3a = current VCC = 0.612 V (operating point)
4 = PEP = -3.4 dBm; current Pinmax limit
4a = current VCC limit = 1.682 V
5 = crest factor = 11.6 dB
6 = operating point
7 = current envelope shape

4. Select "I/Q Analog Output > State > On"

5. Enable "RF > State > On".

6. Trigger the signal generation

7. Select "I/Q Out > I/Q Analog > I/Q Analog Outputs > General", enable "Power Off-
set = 1 dB" and compare the operating point.

The level display value in the status bar of the instrument shows "Level = -14 dBm"
and confirms that a "Level Offset = Power Offset = 1 dB" is enabled.

The instrument generates and outputs:
● An RF signal with the specified level and level offset
● An RF envelope signal that follows the power changes of the RF signal.
The envelope signal E is output at the I OUT connector; the inverted envelope sig-
nal E BAR at the I BAR OUT. The voltage of this envelope signal is automatically
adjusted so that the supply voltage stays within the specified limits.
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To observe the impact of baseband signal and its crest factor on the generated
envelope signal, try out the following:
● Select "Baseband > Off" and compare the displayed envelope shape, in partic-

ular the shaded area.
● Select "Baseband > On", enable "Baseband > EUTRA/LTE > Filter/Clipping/

ARB... > Clipping > State > On" and select "Clipping Level = 75%"

Possible extensions

Consider to extend the test setup as follows:
● To apply digital predistortion (DPD) on the baseband signal and compare the

behavior of the power amplifier (DUT)
See Chapter 6, "How to Apply a Digital Predistortion to Improve the Efficiency of
RF Power Amplifiers", on page 74.

● To perform RF analysis, use the R&S®FSW
● To measure and evaluate the AM/AM and AM/PM distortions, use the R&S®FSW-

K18 Power Amplifier and Envelope Tracking Measurements.
● To observe the characteristics of the generated signal, use an oscilloscope, for

example R&S®RTO

How to optimize the signal to improve the linearity and efficiency of the power
amplifier

Refer to Figure 5-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking and digital predistortion. The illustration is intended to explain
the principle in general, not all connections and required equipment are considered.

I BAR OUT
(Rear Panel)

RF Signal

Envelope Signal (E)

RF A

V

Pin

Vcc

Pout

Inverted Envelope Signal (ē)

DC 
Modulator

I OUT
(Rear Panel)
Vout

Vpp

RF 
INPUT

LAN

LAN

AM/AM and AM/PM coefficients

PA

R&S®SMW200A

R&S®FSW, equipped with R&S®FSW-K18

Figure 5-1: Simplified test setup for power amplifier envelope tracking tests with DPD

Use the following general guidelines:

1. Provide the output signal of the DUT to the R&S®FSW and measure the signal.
Suitable RF measurements are the ACLR and EVM characteristics of the signal.
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2. In the R&S SMW, select "I/Q Analog Outputs > Envelope Settings" and vary the
"Envelope to RF Delay" to minimize the ACLR and EVM measured with the
R&S®FSW.

3. Change the shaping method and shaping function and measure the power ampli-
fier characteristics.

Did its linearity and efficiency improved?

4. Use the R&S®FSW-K18 to evaluate the signal, calculate suitable predistortion val-
ues, and store the AM/AM and AM/PM tables.

5. Transfer the predistortion functions to R&S SMW and load them (select "I/Q Mod >
AM/AM AM/PM > Predistortion Settings").
See Chapter 6, "How to Apply a Digital Predistortion to Improve the Efficiency of
RF Power Amplifiers", on page 74.

6. In the R&S®FSW, measure the power amplifier characteristics.

Did its linearity improved?
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6 How to Apply a Digital Predistortion to
Improve the Efficiency of RF Power Amplifi-
ers
Refer to Figure 6-1 for an example of a simplified test setup for power amplifier testing
with envelope tracking and digital predistortion. The illustration is intended to explain
the principle in general, not all the connections and required equipment are consid-
ered.

I BAR OUT
(Rear Panel)

RF Signal

Envelope Signal (E)

RF A

V

Pin

Vcc

Pout

Inverted Envelope Signal (ē)

DC 
Modulator

I OUT
(Rear Panel)
Vout

Vpp

RF 
INPUT

LAN

LAN

AM/AM and AM/PM coefficients

PA

R&S®SMW200A

R&S®FSW, equipped with R&S®FSW-K18

Figure 6-1: Simplified test setup for power amplifier envelope tracking tests with DPD

A real test setup comprises of the following equipment:
● R&S SMW to generate the RF signal, and to calculate and apply the DPD.

In test setups for envelope tracking tests, the R&S SMW also generates the enve-
lope tracking signal.

● R&S®FSW equipped with R&S®FSW-K18 Power Amplifier and Envelope Tracking
Measurements to:
– Measure and analyze the AM/AM and AM/PM predistortion
– Calculate the AM/AM and AM/PM correction tables
– Store and export the correction tables

● DUT, that is the power amplifier.
● Optional, R&S®RTO to monitor the generated envelope signal.

General steps for tests to improve the efficiency of RF power amplifiers

Consider the following general steps:

1. Enable the R&S SMW to generate a baseband signal. A suitable baseband signal
is a simple ramp function or, to minimize memory effects, a signal with small band-
width.
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2. Compare the input waveform to the output of the power amplifier and determine
how the amplifier is distorting the signal.
The normalized AM/AM and AM/PM curves show the variation of the magnitude
and phase over the variation of the input power and thus provide a suitable repre-
sentation and good basis for analysis.

3. A simple straightforward method to retrieve the DPD correction values is to "invert"
the curves, see Chapter 4.2.3, "Finding Out the Correction Values", on page 52.
Use the R&S®FSW-K18 to retrieve the AM/AM and AM/PM correction values auto-
matically.

4. Use the retrieved correction values and define the predistortion functions.

5. Enable the AM/AM and AM/PM predistortion and predistort the original baseband
signal.
See "To configure the R&S SMW to predistort the baseband signal" on page 75

6. Measure the behavior of the power amplifier, for example perform EVM and ACP
measurements or evaluate the AM/AM and AM/PM curves.

Does the output signal of the DUT have a better performance with regards to ACP
and/or EVM?

To configure the R&S SMW to predistort the baseband signal

1. Enable the R&S SMW to generate an EUTRA/LTE FDD DL signal.

2. Set "Frequency = 2.143 GHz" and "Level = -15 dB".

3. In the block diagram, select "I/Q Mod > Digital Predistortion > AM/AM, AM/PM",
and perform the following:

a) Select "Digital Predistortion AM/AM, AM/PM > Predistortion Settings" and
enable "Shaping > From Table".

b) Select "AM/AM Table > New", enter a file name, and select "AM/AM Table >
Edit".

c) Enter the correction values and select "Save".
See the example on Figure 4-3.

d) Adjust the AM/PM correction values in the same way.
e) Select "Interpolation > Liner (Power)".
f) Select "Digital Predistortion AM/AM, AM/PM > General".
g) Select "Maximum Input Power PEPIN Max > 3 dBm".
h) Select "AM/AM State > On", "AM/PM State > On" and "Predistortion State >

On".
i) Select "Level Reference > After DPD", "Maximum Output Level Error = 0.1 dB"

and "Maximum Number of Iterations = 3".

4. Enable "RF > State > On".

5. Trigger the signal generation
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To perform manual iterations to achieve a desired resulting signal level after the
DPD

To explain the iteration principle, we assume that the R&S SMW has been configured
as described in "To configure the R&S SMW to predistort the baseband signal"
on page 75 and the DPD uses an AM/AM predistortion function as shown on Fig-
ure 6-2.

To achieve a signal level of -15 dB after the DPD, perform the following steps and obey
the rule:

Vary the "Level" with small steps.
Always start with small value and increase the "Level" at the subsequent iterations.

1. Select "Digital Predistortion AM/AM, AM/PM > General > Level reference > Before
DPD".

2. Calculate the ΔP_1.



How to Apply a Digital Predistortion to Improve the Efficiency
of RF Power Amplifiers

R&S®SMW-K540, R&S®SMW-K541

77User Manual 1176.9506.02 ─ 07

Figure 6-2: Manual iterations on an example AM/AM predistortion function ("Input Range PEPin =
-17 dBm to -12 dBm"): Step#1

1 = current operating point: PIN = LevelIN_1 = -15 dBm
2 = first iteration with LevelIN_2

a = ΔP_1

b = difference between the correction values at the current and the new operating points

● LevelIN_1 = Level = -15 dBm
● LevelOUT_1 = -15.42 dBm
● ΔP_1 = Level - LevelOUT_1 = -15 + 15.42 = 0.42 dBm

3. Set the "Level" = Level + ΔP_1 = -15.45 dBm.

The diagram displays the achieved output values; LevelOUT_2 = - 15.02 dBm.

4. Calculate the ΔP_2.
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Figure 6-3: Manual iterations on an example AM/AM predistortion function ("Input Range PEPin =
-17 dBm to -12 dBm"): Step#2

1 = initial operating point: PIN = LevelIN_1 = -15 dBm
2 = current operating point: PIN = LevelIN_2 = -15.45 dBm
3 = second iteration with LevelIN_3

a = ΔP_2

b = difference between the correction values at the current and the new operating points

● LevelIN_2 = - 15.55
● LevelOUT_2 = -15.02 dBm
● ΔP_2 = Level - LevelOUT_2 = -15 + 15.02 = - 0.02 dBm

5. Set "Level" = Level + ΔP_2 = -15.43 dBm

The diagram confirms the achieved output value; LevelOUT_3 = - 15 dBm.
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6. Compare the operating point on the AM/AM functions.



Remote-Control CommandsR&S®SMW-K540, R&S®SMW-K541

80User Manual 1176.9506.02 ─ 07

7 Remote-Control Commands
The following commands are required to perform signal generation with the
R&S SMW-K540/-K541 options in a remote environment. We assume that the
R&S SMW has already been set up for remote operation in a network as described in
the R&S SMW user manual. A knowledge about the remote control operation and the
SCPI command syntax are assumed.

Conventions used in SCPI command descriptions
For a description of the conventions used in the remote command descriptions, see
section "Remote Control Commands" in the R&S SMW user manual.

Common Suffixes

The following common suffixes are used in remote commands:

Suffix Value range Description

SOURce<hw> [1]|4 Available baseband signals

Programming Examples

The corresponding sections of the same title provide simple programming examples for
the R&S SMW. The purpose of the examples is to present all commands for a given
task. In real applications, one would rather reduce the examples to an appropriate sub-
set of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of the most remote control program, an instrument (p)reset is recom-
mended to set the R&S SMW to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

In all the examples we assume that a remote PC is connected to the instrument, the
remote PC and the instrument are switched on, a connection between them is estab-
lished and the security setting "System Config > Setup > Security > SCPI over LAN" is
enabled.

The following commands specific to the R&S SMW-K540/-K541 options are described
here:

● SOURce:IQ:OUTPut Subsystem............................................................................ 81
● SOURce:IQ:OUTPut:ENVelope Commands...........................................................83
● SOURce:IQ:DPD Subsystem..................................................................................99
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7.1 SOURce:IQ:OUTPut Subsystem

This section describes the commands of the output of an analog I/Q signal.

[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe......................................................................81
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet...................................................................81
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog?.................................................. 81
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe......................................................82
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD........................................................82
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete......................................................82
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE......................................................................82

[:SOURce<hw>]:IQ:OUTPut:ANALog:STATe <State>

Activates the specified analog I/Q output.

Note: By default, the output connectors I/Q OUT 1/2 are deactivated.

Suffix: 
:SOURce<hw>

.
1|2
Determines the connectors, I/Q OUT 1 or I/Q OUT 2

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SOURce:IQ:OUTPut:ANALog:STATe ON
activates the output of the analog I/Q signal on the I/Q OUT 1
connectors.

Manual operation: See "State" on page 23

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:PRESet

Sets the default settings (*RST values specified for the commands).

Not affected is the state set with the command [:SOURce<hw>]:IQ:OUTPut:
ANALog:STATe.

Usage: Event

Manual operation: See "Set to Default" on page 23

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:CATalog?

Queries the files with I/Q output settings in the default directory. Listed are files with the
file extension *.iqout.

Return values: 
<Catalog> "<filename1>,<filename2>,..."

Returns a string of file names separated by commas.

Usage: Query only

 

SOURce:IQ:OUTPut Subsystem



Remote-Control CommandsR&S®SMW-K540, R&S®SMW-K541

82User Manual 1176.9506.02 ─ 07

Manual operation: See "Save/Recall" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:STORe <Filename>

Stores the current settings into the selected file; the file extension (*.iqout) is
assigned automatically.

Setting parameters: 
<Filename> string

Usage: Setting only

Manual operation: See "Save/Recall" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.iqout.

Setting parameters: 
<Filename> string

Usage: Setting only

Manual operation: See "Save/Recall" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:SETTing:DELete <Filename>

Deletes the selected file from the default or specified directory. Deleted are files with
the file extension *.iqout.

Setting parameters: 
<Filename> string

Usage: Setting only

Manual operation: See "Save/Recall" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:TYPE <Type>

Determines the type of the analog signal.

Parameters:
<Type> SINGle | DIFFerential

*RST: SINGle

Example: SOURce1:IQ:OUTPup:ANALog:TYPE DIFFerential
Manual operation: See "I/Q Output Type" on page 25

SOURce:IQ:OUTPut Subsystem
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7.2 SOURce:IQ:OUTPut:ENVelope Commands

The following remote control commands require software option R&S SMW-K540.

 

SOURce:IQ:OUTPut:ENVelope Commands
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Example: Generating an RF envelope signal and defining the shaping function
*RST
// enable LTE signal
SOURce1:BB:EUTRa:SETTing:TMOD:DL "E-TM1_1__5MHz"
SOURce1:BB:EUTRa:STATe 1

// define the RF level and frequency
SOURce1:FREQuency:CW 2143000000
SOURce1:POWer:LEVel:IMMediate:AMPLitude -15
SOURce1:POWer:LEVel:IMMediate:OFFSet 0.5
SOURce1:CORRection:VALue?
// Response: 1

// enable RF envelope generation and define the settings
SOURce1:IQ:OUTPut:ANALog:ENVelope:STATe 1
SOURce1:IQ:OUTPut:ANALog:ENVelope:ADAPtion AUTO
SOURce1:IQ:OUTPut:ANALog:TYPE DIFF
SOURce1:IQ:OUTPut:ANALog:ENVelope:ETRak USER
SOURce1:IQ:OUTPut:ANALog:ENVelope:VREF VCC
SOURce1:IQ:OUTPut:ANALog:ENVelope:POWer:OFFSet?
// Response: 1.5

SOURce1:IQ:OUTPut:ANALog:ENVelope:VPP:MAX 4
SOURce1:IQ:OUTPut:ANALog:ENVelope:GAIN 0
SOURce1:IQ:OUTPut:ANALog:ENVelope:EMF:STATe 1
SOURce1:IQ:OUTPut:ANALog:ENVelope:RIN 50
SOURce1:IQ:OUTPut:ANALog:ENVelope:TERMination GROund
SOURce1:IQ:OUTPut:ANALog:ENVelope:BINPut 1
SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:OFFSet 2

SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:MIN 0.5
SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:MAX 2.5

SOURce1:IQ:OUTPut:ANALog:ENVelope:BIAS 0
SOURce1:IQ:OUTPut:ANALog:ENVelope:OFFSet -2
SOURce1:IQ:OUTPut:ANALog:ENVelope:VOUT:MAX?
// Response: 0.5
SOURce1:IQ:OUTPut:ANALog:ENVelope:VOUT:MIN?
// Response: -1.5

SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MIN -30
SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MAX 0

SOURce1:IQ:OUTPut:ANALog:ENVelope:DELay 0.00000000001
SOURce1:IQ:OUTPut:ANALog:ENVelope:FDPD OFF

// enable envelope shaping
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE DETR
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:FUNCtion F3
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:COUPling OFF

SOURce:IQ:OUTPut:ENVelope Commands
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// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:FACtor 0.225
// SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:DETRoughing:PEXPonent 1

// quering the oprating point level, current PEP and levels
// SOURce1:IQ:OUTPut:ANALog:ENVelope:ADAPtion?
// Response: Auto
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue:LEVel?
// Response: 0.927
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue:PEP?
// Response: 1.922
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? 1,NORM,VOLT
// Response: 2.5
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? 0,NORM,VOLT
// Response: 0.563
// SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MAX?
// Response: 0
// SOURce1:IQ:OUTPut:ANALog:ENVelope:PIN:MIN?
// response: -30
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? 0,DBM,POW
// Response: 2.5
// SOURce1:IQ:OUTPut:ANALog:ENVelope:VCC:VALue? -30,DBM,POW
// Response: 0.563

SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE TABL
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:PV:FILE:CATalog?
// Response: myLUT_pv
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:PV:FILE:SELect "/var/user/myLUT_pv.iq_lutpv"
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:INTerp LIN
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:SCALe POWer

// change the envelope shaping mode
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE POLY
// query files with polynomial functions in the default user directory
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients:CATalog?
// Response: env_poly_evm,myPoly
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients:LOAD "myPoly"
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients?
// Response: 0.135,0.82
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients 0.135,0.83
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:COEFficients:STORe "/var/user/myPoly.iq_poly"

// enable the outputs
SOURce1:IQ:OUTPut:ANALog:STATe 1
OUTPut1:STATe 1

// store the settings
MMEMory:CDIRectory "/var/user/setups"
SOURce1:IQ:OUTPut:ANALog:SETTings:CATalog? 
// Response: etrak_v1-2
SOURce1:IQ:OUTPut:ANALog:SETTings:STORe "my_ET"

SOURce:IQ:OUTPut:ENVelope Commands
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SOURce1:IQ:OUTPut:ANALog:PREset
// change the envelope voltage adaptation mode
SOURce1:IQ:OUTPut:ANALog:ENVelope:ADAPtion MAN

SOURce1:IQ:OUTPut:LEVel 4

SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:GAIN:PRE -3
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:GAIN:POST 2.5

// change the envelope shaping mode
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:MODE TABL
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:FILE:CATalog?
// Response: myLUT_vv
SOURce1:IQ:OUTPut:ANALog:ENVelope:SHAPing:FILE:SELect "/var/user/myLUT_vv.iq_lut"

// set the shaping values in raw format
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA  0,0, 0.1,0.2, 1,1
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
// Response: myLUT_vv
// set the shaping values and store them into a file
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW "LUT_vv_raw", 0,0, 0.1,0.2, 1,1.5
// SOURce1:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
// Response: myLUT_vv, LUT_vv_raw

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:STATe.....................................................87
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ADAPtion.................................................87
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ETRak.....................................................88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VREF...................................................... 88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:DELay..................................................... 88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:FDPD......................................................88
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MIN...............................................89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MAX..............................................89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BIAS....................................................... 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:OFFSet................................................... 89
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VPP[:MAX]...............................................90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:EMF[:STATe]........................................... 90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:RIN......................................................... 90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:TERMination............................................ 90
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BINPut.....................................................91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:GAIN.......................................................91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet............................................91
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MIN................................................. 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MAX................................................ 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:PEP?.................................... 92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:LEVel?..................................92
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue?............................................93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MIN...................................................93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MAX................................................. 93
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?...................................... 94
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Remote-Control CommandsR&S®SMW-K540, R&S®SMW-K541

87User Manual 1176.9506.02 ─ 07
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:STATe <State>

Enables the output of a control signal that follows the RF envelope.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "RF Envelope" on page 24

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ADAPtion <AdaptionMode>

Defines the envelope voltage adaption mode.

Parameters:
<AdaptionMode> AUTO | MANual | POWer

AUTO = Auto Normalized, POWer = Auto Power, MANual = Man-
ual
*RST: AUTO

Example: See Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Envelope Voltage Adaptation" on page 24
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:ETRak <ETrakIfcType>

Selects one of the predefined interface types or allows user-defined settings.

See Table 3-1.

Parameters:
<ETrakIfcType> USER | E1V2 | E1V5 | E2V0

*RST: USER

Example: SOURce1:IQ:OUTPut:ANALog:ENVelope:ETRak E2V0
Manual operation: See "eTrak® Interface Type" on page 25

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VREF <VoltageReferenc>

Defines whether the envelope voltage Vout is set directly or it is estimated from the
selected supply voltage Vcc.

Parameters:
<VoltageReferenc> VCC | VOUT

*RST: VCC

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Envelope Voltage Reference" on page 25

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:DELay <Delay>

Enables a time delay of the generated envelope signal relative to the corresponding
RF signal.

Parameters:
<Delay> float

Range: -500E-9  to  500E-9
Increment: 1E-12
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Envelope to RF Delay" on page 32

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:FDPD <CalcFromDpdStat>

Enables calculation of the envelope from predistorted signal.

Parameters:
<CalcFromDpdStat> 0 | 1 | OFF | ON

*RST: 0
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Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Options: R&S SMW-K540/K541

Manual operation: See "Calculate Envelope form Predistorted Signal" on page 32

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MIN <VoutMin>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VOUT:MAX <VoutMax>

Queries the minimum and maximum values of the estimated envelope output voltage
Vout.

Parameters:
<VoutMax> float

Range: 0.04  to  8
Increment: 1E-3
*RST: 1

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "VoutMin/Max" on page 25

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BIAS <Bias>

Sets a bias.

Parameters:
<Bias> float

Range: -4  to  4
Increment: 1E-4
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Bias" on page 26

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:OFFSet <Offset>

Sets an offset between the envelope and the inverted envelope signal.

Parameters:
<Offset> float

Range: -4  to  4
Increment: 1E-4
*RST: 0
Default unit: mV

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84
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Manual operation: See "Offset" on page 26

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VPP[:MAX] <VppMax>

Set the maximum value of the driving voltage Vpp of the used external DC modulator.

Parameters:
<VppMax> float

Range: 0.04  to  8
Increment: 1E-3
*RST: 1

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "VppMax" on page 29

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:EMF[:STATe] <EmfState>

Defines whether the EMF or the voltage value is used.

Parameters:
<EmfState> 0 | 1 | OFF | ON

*RST: 1

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "EMF" on page 27

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:RIN <InputResistance>

Sets the input impedance Rin of the used external DC modulator.

Parameters:
<InputResistance> float

Range: 50|100  to  1E6
Increment: 0.1
*RST: 50

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Rin" on page 27

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:TERMination <Termination>

Sets how the inputs of the DC modulator are terminated.

Parameters:
<Termination> GROund | WIRE

*RST: GROund
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Example: See Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Termination" on page 27

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:BINPut <BipolarInput>

Enables the generation of a bipolar signal.

Parameters:
<BipolarInput> 0 | 1 | OFF | ON

*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Bipolar Input" on page 28

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:GAIN <Gain>

Sets the gain of the used external DC modulator.

Parameters:
<Gain> float

Range: -50  to  50
Increment: 0.01
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Gain" on page 29

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:OFFSet <VccOffset>

Applies a voltage offset on the supply voltage Vcc.

Parameters:
<VccOffset> float

Range: 0  to  10
Increment: 1E-3
*RST: 0
Default unit: mV

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "VccOffset" on page 29
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MIN <VccMin>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:MAX <VccMax>

Sets the maximum value of the supply voltage Vcc.

Parameters:
<VccMax> float

Range: 0.04  to  8
Increment: 0.001
*RST: 1

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "VccMin/Max" on page 30

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:PEP?

Queries the Vcc value of the current PEP of the generated RF signal.

Return values: 
<VccForCrtPep> float

Range: 0  to  38
Increment: 1E-3
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Query only

Manual operation: See "Diagram" on page 41

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue:LEVel?

Queries the Vcc value of the current RMS power level (operating point).

Return values: 
<VccForRfLevel> float

Range: 0  to  38
Increment: 1E-3
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Query only

Manual operation: See "Diagram" on page 41
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:VCC:VALue? <xValue>, <xUnit>,
<xScale>

Queries the VCC value for the selected <xValue>.

Query parameters: 
<xValue> float

Value on the x-axis
Value range depends on the selected "Envelope Voltage Adap-
tation" and PEPinMin and PEPinMax values.

<xUnit> NORMalized | DBM | V
*RST: NORMalized

<xScale> VOLTage | POWer
*RST: VOLTage

Return values: 
<VccValue> float

Range: 0  to  38
Increment: 1E-3
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Query only

Manual operation: See "Diagram" on page 41

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MIN <PinMin>

Sets the minimum value of the input power Pin.

Parameters:
<PinMin> float

Range: -145  to  20
Increment: 0.01
*RST: -30

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "PEPinMin/Max" on page 30

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:PIN:MAX <PinMax>

Sets the maximum value of the input power Pin.
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Parameters:
<PinMax> float

Range: -145  to  20
Increment: 0.01
*RST: -20

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "PEPinMin/Max" on page 30

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:POWer:OFFSet?

Queries the current power offset, that is the sum of enabled "RF Level > Offset" and
"User Correction".

Return values: 
<PowerOffset> float

Range: -200  to  200
Increment: 0.01
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Query only

Manual operation: See "Power Offset" on page 30

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:MODE
<ShapingMode>

Enables envelope shaping and selects the method to define the shaping function.

Parameters:
<ShapingMode> OFF | LINear | TABLe | POLYnomial | DETRoughing | POWer

LINear = Linear (Voltage)
POWer = Linear (Power)

*RST: OFF

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Shaping" on page 34

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:SCALe <Scale>

Determines the units used on the x and y axis.

Parameters:
<Scale> POWer | VOLTage

*RST: VOLTage
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Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Scale" on page 41

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:PRE <PreGain>
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:GAIN:POST

<PostGain>

Sets a post-gain.

Parameters:
<PostGain> float

Range: -3  to  20
Increment: 1E-2
*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Post-Gain" on page 39

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:CATalog?
[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:CATalog?
Queries the available table shaping files in the default directory. Only files with the file
extension *.iq_lut or *.iq_lutpv are listed.

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Query only

Manual operation: See "Shaping Table" on page 39

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE[:SELect]
<Filename>

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE[:SELect]
<Filename>

Selects an envelope shaping file (extension *.iq_lut or *.iq_lutpv).

Parameters:
<Filename> string

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Shaping Table" on page 39
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:DATA <Vin/
Vmax>,<Vcc/Vmax>[,<Vin/Vmax>,<Vcc/Vmax>...]

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:DATA
<P>,<Vcc>[,<P>,<Vcc>, ...]

Defines the shaping function in a raw data format.

See also [:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:
FILE:NEW on page 96.

Parameters:
<P>,<Vcc> Sequence of up to 4000 comma-separated value pairs.

Example: See Example "Generating an RF envelope signal and defining
the shaping function" on page 84

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:FILE:NEW
<Filename>,<Vin/Vmax>,<Vcc/Vmax>

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:PV:FILE:NEW
<Filename>,<P>,<Vcc>

Stores the shaping values into a file with the selected file name and loads it.

The file is stored in the default directory or in the directory specified with the absolute
file path. If the file does not yet exist, a new file is created. The file extension is
assigned automatically.

Setting parameters: 
<Filename> string

<P>,<Vcc> value pairs

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Setting only

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:INTerp <Interpolation>

For envelope shaping with shaping tables, enables linear interpolation.

Parameters:
<Interpolation> OFF | LINear | POWer

LINear = Linear (Voltage)
POWer = Linear (Power)

*RST: OFF

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Interpolation" on page 40
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients

Sets the polynomial coefficients.

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Polynomial Order" on page 45
See "Polynomial constant and coefficients" on page 45
See "Apply, OK" on page 45

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:
CATalog?

Queries the available polynomial files in the default directory. Only files with the file
extension *.iq_poly are listed.

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Query only

Manual operation: See "Save/Recall Polynomial" on page 45

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:STORe
<Filename>

Saves the polynomial function as polynomial file.

Setting parameters: 
<Filename> string

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 45

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:COEFficients:LOAD
<Filename>

Loads the selected polynomial file.

Setting parameters: 
<Filename> string

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 45
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[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FUNCtion <DetrFunction>

Sets the detroughing function.

Parameters:
<DetrFunction> F1 | F2 | F3

*RST: F1

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Detroughing Function" on page 38

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
COUPling <CouplingState>

Enables/disables deriving the detroughing factor (d) from the selected Vcc value.

Parameters:
<CouplingState> 0 | 1 | OFF | ON

*RST: 0

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Couple Detroughing Factor with Vcc" on page 38

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
FACTor <DetrFactor>

Sets the detroughing factor.

Parameters:
<DetrFactor> float

Range: 0  to  2
Increment: 1E-3
*RST: 0.2

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Detroughing Factor (d)" on page 39

[:SOURce<hw>]:IQ:OUTPut[:ANALog]:ENVelope:SHAPing:DETRoughing:
PEXPonent <PowerExponent>

Sets the exponent (a) for the detroughing function F3.
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Parameters:
<PowerExponent> float

Range: 1  to  10
Increment: 1E-3
*RST: 2

Example: see Example "Generating an RF envelope signal and defining
the shaping function" on page 84

Manual operation: See "Exponent (a)" on page 39

7.3 SOURce:IQ:DPD Subsystem

The SOURce:IQ:DPD subsystem contains the commands for enabling and configuring
of digital predistortion.

For information about the required options, see Chapter 4.1, "Required Options",
on page 46.

Example: Defining correction coefficients and enabling digital predistortion
*RST

// enable LTE signal
SOURce1:BB:EUTRa:SETTing:TMOD:DL "E-TM1_1__5MHz"
SOURce1:BB:EUTRa:STATe 1

// define the RF level and frequency
SOURce1:FREQuency:CW 2143000000
SOURce1:POWer:LEVel:IMMediate:AMPLitude -15

SOURce1:IQ:DPD:PIN:MIN -35
SOURce1:IQ:DPD:PIN:MAX -2.5

// select look-up table files with correction values
SOURce1:IQ:DPD:SHAPing:MODE TABLe
SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?
// Response: My_DPD_AM-AM,MyDPD_AM-AM
SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:SELect "My_DPD_AM-AM"
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
// Response: My_DPD_AM-PM,MyDPD_AM-PM
SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:SELect "My_DPD_AM-PM"
SOURce1:IQ:DPD:SHAPing:TABLe:INTerp LINer
SOURce1:IQ:DPD:SHAPing:TABLe:INVert?
// Response: 0

// enable digital predistortion
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SOURce1:IQ:DPD:AMPM:AMFirst 1
SOURce1:IQ:DPD:AMAM:STATe 1
SOURce1:IQ:DPD:AMPM:STATe 1
SOURce1:IQ:DPD:LREFerence BDPD
SOURce1:IQ:DPD:STATe 1

// enable the output
SOURce1:IQ:STATe 1
OUTPut1:STATe 1

// query the PEP, level and crest factor values before and after the DPD
SOURce1:IQ:DPD:INPut:PEP?
// Response: -3.43
SOURce1:IQ:DPD:INPut:LEVel?
// Response: -15
SOURce1:IQ:DPD:INPut:CFACtor?
// Response: 11.57

SOURce1:IQ:DPD:OUTPut:PEP?
SOURce1:IQ:DPD:OUTPut:LEVel?
SOURce1:IQ:DPD:OUTPut:CFACtor?

// change level reference and 
// query the PEP, level and crest factor values before and after the DPD
SOURce1:IQ:DPD:LREFerence ADPD
SOURce1:IQ:DPD:OUTPut:ERRor:MAX 0.1
SOURce1:IQ:DPD:OUTPut:ITERations:MAX 3
SOURce1:IQ:DPD:MEASurement:STATe?
// Response: 1
SOURce1:IQ:DPD:OUTPut:ERRor?
// Response: 0
SOURce1:IQ:DPD:OUTPut:PEP?
// Response: -3.57
SOURce1:IQ:DPD:OUTPut:LEVel?
// Response: -15
SOURce1:IQ:DPD:OUTPut:CFACtor?
// Response: 11.43

// enable static DPD and set the pre-gain
// SOURce1:IQ:DPD:LREFerence SDPD
// SOURce1:IQ:DPD:GAIN:PRE -18
// set the predistorion values in raw format
// SOURce1:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA -30.4,-5.2, -25.1,-4.5, -18.5,-2.5, -10.5,-1
// SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA -30.4, -5, -25.1, 5, -10, 0
// SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
// Response: My_DPD_AM-PM,MyDPD_AM-PM
// set the predistorion values and store them into a file
// SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW "DPD_AM-PM_raw", -30.4, -5, -25.1, 5, -10, 0
// SOURce1:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
// Response: My_DPD_AM-PM,MyDPD_AM-PM,DPD_AM-PM_raw
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// SOURce1:IQ:DPD:AMPM:VALue:PEP?
// Response: 4.255
// SOURce1:IQ:DPD:AMPM:VALue:VALue? -30,DBM
// Response:-4.439

// change the shaping mode
SOURce1:IQ:DPD:SHAPing:MODE POLYnomial
// query files with polynomial functions in the default user directory
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?
// Response: MyDTD_Poly,myDTD_Poly4th
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD "MyDTD_Poly4th"
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients?
// Response: 0,0,-0.25,0.2,0.6,-0.3,0.3,0.3,0.5,-0.4
SOURce1:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe "/var/user/myPoly.dpd_poly"
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[:SOURce<hw>]:IQ:DPD:LREFerence..............................................................................104
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor?........................................................................104
[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX..................................................................104
[:SOURce<hw>]:IQ:DPD:OUTPut:ITERations:MAX........................................................... 105
[:SOURce<hw>]:IQ:DPD:MEASurement:STATe?.............................................................. 105
[:SOURce<hw>]:IQ:DPD:INPut:CFACtor?........................................................................ 105
[:SOURce<hw>]:IQ:DPD:OUTPut:CFACtor?.....................................................................105
[:SOURce<hw>]:IQ:DPD:INPut:LEVel?............................................................................ 105
[:SOURce<hw>]:IQ:DPD:OUTPut:LEVel?.........................................................................105
[:SOURce<hw>]:IQ:DPD:INPut:PEP?...............................................................................105
[:SOURce<hw>]:IQ:DPD:OUTPut:PEP?........................................................................... 105
[:SOURce<hw>]:IQ:DPD:PIN:MIN....................................................................................105
[:SOURce<hw>]:IQ:DPD:PIN:MAX...................................................................................105
[:SOURce<hw>]:IQ:DPD:GAIN:PRE................................................................................ 106
[:SOURce<hw>]:IQ:DPD:SHAPing:MODE........................................................................ 106
[:SOURce<hw>]:IQ:DPD:SCALe......................................................................................106
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?...................................... 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?...................................... 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect]........................................ 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect]........................................ 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:NEW............................................. 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW............................................. 107
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA............................................ 108
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA............................................ 108
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:INTerp............................................................. 108
[:SOURce<hw>]:IQ:DPD:SHAPing[:TABLe]:INVert............................................................ 108
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[:SOURce<hw>]:IQ:DPD:STATe <State>

Enabels/disables the generation of digitally pre-distorted signals.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "State" on page 54

[:SOURce<hw>]:IQ:DPD:PRESet

Sets the default DPD settings (*RST values specified for the commands).

Not affected is the state set with the command [:SOURce<hw>]:IQ:DPD:STATe.

Usage: Event

Manual operation: See "Set to Default" on page 54

[:SOURce<hw>]:IQ:DPD:SETTing:CATalog?

Queries the files with digital predistortion setting in the default directory. Listed are files
with the file extension *.dpd.

Return values: 
<Catalog> "<filename1>,<filename2>,..."

Returns a string of file names separated by commas.

Usage: Query only

Manual operation: See "Save/Recall" on page 54
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[:SOURce<hw>]:IQ:DPD:SETTing:DELete <Filename>

Deletes the selected file from the default or specified directory. Deleted are files with
the file extension *.dpd.

Setting parameters: 
<Filename> string

Usage: Setting only

Manual operation: See "Save/Recall" on page 54

[:SOURce<hw>]:IQ:DPD:SETTing:LOAD <Filename>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.dpd.

Setting parameters: 
<Filename> string

Usage: Setting only

Manual operation: See "Save/Recall" on page 54

[:SOURce<hw>]:IQ:DPD:SETTing:STORe <Filename>

Stores the current settings into the selected file; the file extension (*.dpd) is assigned
automatically.

Setting parameters: 
<Filename> string

Usage: Setting only

Manual operation: See "Save/Recall" on page 54

[:SOURce<hw>]:IQ:DPD:AMAM:STATe <State>
[:SOURce<hw>]:IQ:DPD:AMPM:STATe <State>

Enabels/disables the AM/AM and AM/PM digital predistortion.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "AM/AM and AM/PM State" on page 55

[:SOURce<hw>]:IQ:DPD:AMFirst <AmAmFirstState>

Sets that the AM/AM predistortion is applied before the AM/PM.
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Parameters:
<AmAmFirstState> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "AM/AM First" on page 54

[:SOURce<hw>]:IQ:DPD:LREFerence <LevelReference>

Sets whether a dynamic (BDPD|ADPD) or a static (SDPS) adaptation of the range the
selected DPD is applied on.

Parameters:
<LevelReference> BDPD | ADPD | SDPD

*RST: BDPD

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Level Reference" on page 54

[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor?

Queries the resulting level error.

Return values: 
<AchievedError> float

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

Manual operation: See "Achieved Output Level Error" on page 55

[:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX <MaximumError>

Sets the allowed maximum error.

Parameters:
<MaximumError> float

Range: 0.01  to  1
Increment: 0.01
*RST: 0.1

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Maximum Output Level Error" on page 55
See "Maximum Number of Iteractions" on page 55
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[:SOURce<hw>]:IQ:DPD:OUTPut:ITERations:MAX <MaxIterations>

Sets the maximum number of performed iterations to achieving the required error set
with [:SOURce<hw>]:IQ:DPD:OUTPut:ERRor:MAX.

Parameters:
<MaxIterations> integer

Range: 1  to  10
*RST: 3

Example: See Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

[:SOURce<hw>]:IQ:DPD:MEASurement:STATe?

Queries whether the interactions are competed.

Return values: 
<MeasureValidity> 0 | 1 | OFF | ON

*RST: 1

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

[:SOURce<hw>]:IQ:DPD:INPut:CFACtor?
[:SOURce<hw>]:IQ:DPD:OUTPut:CFACtor?
[:SOURce<hw>]:IQ:DPD:INPut:LEVel?
[:SOURce<hw>]:IQ:DPD:OUTPut:LEVel?
[:SOURce<hw>]:IQ:DPD:INPut:PEP?
[:SOURce<hw>]:IQ:DPD:OUTPut:PEP?
Queries the measured values the before and after the enabled digital predistortion.

Return values: 
<PEP> float

The query returns -1000 if the calculation is impossible or there
are no measurements results available.

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

Manual operation: See "Input/Output PEP, Level and Crest Factor" on page 55

[:SOURce<hw>]:IQ:DPD:PIN:MIN <PepInMin>
[:SOURce<hw>]:IQ:DPD:PIN:MAX <PepInMax>

Sets the value range of the input power.
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Parameters:
<PepInMax> float

Range: -145  to  20
Increment: 0.01
*RST: 10

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Input Range (PEPin)" on page 58

[:SOURce<hw>]:IQ:DPD:GAIN:PRE <PreGain>

Sets a pre-gain (i.e. an attenuation) to define the range the static DPD is applied in.

Parameters:
<PreGain> float

Range: -50  to  20
Increment: 1E-2
*RST: 0

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Pre-Gain" on page 58

[:SOURce<hw>]:IQ:DPD:SHAPing:MODE <Shaping>

Selects the method to define the correction coefficients.

Parameters:
<Shaping> TABLe | POLYnomial | NORMalized

*RST: TABLe

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Shaping" on page 57

[:SOURce<hw>]:IQ:DPD:SCALe <Scale>

Determines the units used on the x and y-axis.

Parameters:
<Scale> POWer | VOLTage

*RST: POWer

Manual operation: See "Scale" on page 59
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[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:CATalog?
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:CATalog?
Queries the available table files in the default directory. Only files with the extension
*.dpd_magn(AM/AM) or *.dpd_phase(AM/PM) are listed.

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

Manual operation: See "Shaping Table" on page 59

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE[:SELect] <Filename>
[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE[:SELect] <Filename>

Selects a file with correction values (extension *.dpd_magn (AM/AM) or
*.dpd_phase(AM/FM)).

Parameters:
<Filename> string

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Shaping Table" on page 59
See "Pin (dBm), Delta Power (dB) / Pin (dBm), Delta Phase
(deg)" on page 61

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:NEW
<Filename>,<Pin>,<Delta>

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW
<Filename>,<Pin>,<Delta>

Stores the correction values into a file with the selected file name and loads it.

The file is stored in the default directory or in the directory specified with the absolute
file path. If the file does not yet exist, a new file is created. The file extension is
assigned automatically.

Setting parameters: 
<Filename> string

<Pin>,<Delta> Value pairs, describing the absolute input power Pin and the
delta values for amplitude or phase.

Example: See Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Setting only
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[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMAM:FILE:DATA
<Pin>,<Delta>[,<Pin>,<Delta>, ...]

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:DATA
<Pin>,<Delta>[,<Pin>,<Delta>, ...]

Defines the predistortion function in a raw data format.

See also [:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:AMPM:FILE:NEW
on page 107.

Parameters:
<Pin>,<Delta> Sequence of up to 4000 comma-separated value pairs, describ-

ing the absolute input power Pin and the delta values for ampli-
tude or phase.

Example: See Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

[:SOURce<hw>]:IQ:DPD:SHAPing:TABLe:INTerp <Interpolation>

Enables a linear (voltage or power) interpolation between the defined correction val-
ues.

Parameters:
<Interpolation> OFF | POWer | LINear

POWer
Linear power interpolation
LINear
Linear voltage interpolation
*RST: OFF

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Interpolation" on page 57

[:SOURce<hw>]:IQ:DPD:SHAPing[:TABLe]:INVert <InvertValues>

Inverts the defined correction values.

Parameters:
<InvertValues> 0 | 1 | OFF | ON

*RST: 0

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Invert correction values" on page 57

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients

Sets the polynomial coefficients.
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Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Manual operation: See "Polynomial Order" on page 65
See "Polynomial coefficients" on page 65

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:CATalog?

Queries the available polynomial files in the default directory. Only files with the file
extension *.dpd_poly are listed.

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

Manual operation: See "Save/Recall Polynomial" on page 64

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:LOAD <Filename>

Loads the selected polynomial file.

Setting parameters: 
<Filename> string

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 64

[:SOURce<hw>]:IQ:DPD:SHAPing:POLYnomial:COEFficients:STORe <Filename>

Saves the polynomial function as polynomial file.

Setting parameters: 
<Filename> string

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Setting only

Manual operation: See "Save/Recall Polynomial" on page 64

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
<#><LengthOfNrOfBytes><NrOfBytes><NormData>

Defines the normalized predistortion function in a raw data format (binary data).

Parameters:
<#> The binary data must start with the sign #
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<LengthOfNrOfBytes>ASCII format
Sets the length of <NrOfBytes>, i.e. the number of digits used
to write <NrOfBytes>

<NrOfBytes> An ASCII integer value that specifies the number of bytes that
follow in the <NormData> part
Each of the <NormData> parameters is coded with 8 bytes.
Then the number of bytes <NrOfBytes> is calculated as:
<NrOfBytes> = 8 + 8 + n(8+8+8), where n is the number of
points <NoOfPoints>.

Setting parameters: 
<NormData> <PinMax><NoOfPoints>{<VinVmax><DeltaV><DeltaPhase>}

Values in binary format, describing the maximum absolute
input power Pinmax, the number of subsequent points n and the
normalized values Vin/Vmax, ΔV/V, ΔPhase [deg].

Example: SOURce1:IQ:DPD:SHAPing:NORMalized:DATA #240<values>
// the binary <values> are not printable
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?
// norm
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:STORe "My_DPD_Normalized"
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?
// norm,My_DPD_Normalized
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA:LOAD "norm"
SOURce1:IQ:DPD:SHAPing:NORMalized:DATA?
// #3112
// the binary data <NormData> is 112 bytes long, i.e. 3 points are defined
// binary data is machine readable but not printable

Manual operation: See "Pinmax" on page 67
See "Vin/Vmax, ΔV/V,ΔPhase (deg)" on page 67

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:CATalog?

Queries the available files with normalized data in the default directory. Only files with
the file extension *.dpd_norm are listed.

Example: see [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
on page 109

Usage: Query only

Manual operation: See "Save/Recall Normalized Data" on page 67

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:LOAD <Filename>

Loads the selected file.

Setting parameters: 
<Filename> string
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Example: see [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
on page 109

Usage: Setting only

Manual operation: See "Save/Recall Normalized Data" on page 67

[:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA:STORe <Filename>

Saves the normalized data in a file.

Setting parameters: 
<Filename> string

Example: see [:SOURce<hw>]:IQ:DPD:SHAPing:NORMalized:DATA
on page 109

Usage: Setting only

Manual operation: See "Save/Recall Normalized Data" on page 67

[:SOURce<hw>]:IQ:DPD:AMAM:VALue:LEVel?
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:LEVel?
Queries the delta phase and delta power values of the current RF RMS power level.

Return values: 
<DeltaPhase> float

Range: -180  to  180
Increment: 0.01
*RST: 0

<DeltaPower> float
Range: -20  to  20
Increment: 0.01
*RST: 0

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 59

[:SOURce<hw>]:IQ:DPD:AMAM:VALue:PEP?
[:SOURce<hw>]:IQ:DPD:AMPM:VALue:PEP?
Queries the delta phase and delta power values for the current PEP of the generated
RF signal.
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Return values: 
<DeltaPhase> float

Range: -180  to  180
Increment: 0.01
*RST: 0

<DeltaPower> float
Range: -20  to  20
Increment: 0.01
*RST: 0

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 59

[:SOURce<hw>]:IQ:DPD:AMAM:VALue?
[:SOURce<hw>]:IQ:DPD:AMPM:VALue?
Queries the delta phase and delta power values for the selected <xValue>.

Query parameters: 
<xValue> float

Value on the x-axis
Value range depends on the selected PEPinMin and PEPinMax
values.

<xUnit> DBM | V
*RST: DBM

Return values: 
<DeltaPhase> float

Range: -180  to  180
Increment: 0.01
*RST: 0

<DeltaPower> float
Range: -20  to  20
Increment: 0.01
*RST: 0

Example: see Example "Defining correction coefficients and enabling digi-
tal predistortion" on page 99

Usage: Query only

Manual operation: See "AM/AM and AM/PM Diagrams" on page 59

[:SOURce<hw>]:IQ:DPD:LRF:STATe <LinearizeRf>

Activates linearization of the RF.
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Parameters:
<LinearizeRf> 0 | 1 | OFF | ON

*RST: 0

Example: SOURce1:IQ:DPD:LRF:STATe 1
SOURce1:IQ:DPD:LRF:ADJust?
// Response: 0

Manual operation: See "Linearize RF" on page 68

[:SOURce<hw>]:IQ:DPD:LRF:ADJust?

Calculates the predistortion values for the current frequency.

Return values: 
<AdjustResult> 0 | 1 | RUNning | STOPped

*RST: STOPped

Usage: Query only

Manual operation: See "Adjust Linearization Current Frequency" on page 69
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